Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem in creating a new blog

  • HI,

    I have downloaded WPMU and BP. First i installed WPMU in my localhost after that i have installed BP then i logged in as admin and i tried to create an another new blog after filling the form it displayed

    ” Congratulations! You have successfully registered a new blog.

    http://trial.127.0.0.1/wpmu/ is your new blog. Login as “admin” using your existing password. “

    also in one more blog is added in my blog list.

    When I tried to enter the dash board of my newly created blog browser displays that “Address not found”.

    Also when i tried with “http://trial.127.0.0.1/wpmu/” in my browser address bar same “Address not found” is displayed.

    Please help me i totally new to this.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    You are running on windows right? Just a guess. Before installing bp you need to get mu running properly. It’s a pain on windows. What package are you using? WAMP?

    To get your subdomains to work you have to edit the ‘hosts’ file in windows for *each* blog you want to have running on your windows box. The hosts file is in:

    Windows 95/98/Me c:windowshosts

    Windows NT/2000/XP Pro c:winntsystem32driversetchosts

    Windows XP and Vista c:windowssystem32driversetchosts

    Once you find it you have to create a line for each blog so:

    127.0.0.1 ourcommoninterest.dev

    127.0.0.1 adminstoy.ourcommoninterest.dev

    That’s a sample from my laptop which I use to play with new things in mu, buddypress and bbpress. This is only the beginning of your problems on windows. I know I went thru *all* of them.

    However, for now, you should replace the domain name with your chosen domain name. Replace the subdomain name with any blog subdomain name you’ve chosen. ‘trial’ in your case.

    Try reading up on what it takes to install mu. Then what it takes to install mu on windows. Google finds lots of things related to mu. Here’s a start:

    http://mu.wordpress.org/forums/topic.php?id=4624

    You also need to follow the directions in the mu readme.txt file as it relates to apache.

    Thanks for ur reply

    but I am using in LINUX (ubuntu) and XAMPP

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Sorry, got excited when I thought I had found a fellow sufferer. :) If your box doesn’t have access to a dns name server you’ll still have to edit your /etc/hosts file probably just like windows. Or install mu with the subdirectory option.

    sorry i can’t get you please give a clear explanation on how to edit /etc/hosts file

    i tried this

    in /etc/hosts file following things where displayed initially

    127.0.0.1 localhost

    127.0.1.1 deek-ubuntu

    # The following lines are desirable for IPv6 capable hosts

    ::1 ip6-localhost ip6-loopback

    fe00::0 ip6-localnet

    ff00::0 ip6-mcastprefix

    ff02::1 ip6-allnodes

    ff02::2 ip6-allrouters

    ff02::3 ip6-allhosts

    then i inserted two lines

    “127.0.0.1 127.0.0.1/wpmu

    127.0.0.1 trial.127.0.0.1/wpmu”

    in that file

    after that it appears like

    127.0.0.1 localhost

    127.0.0.1 127.0.0.1/wpmu

    127.0.0.1 trial.127.0.0.1/wpmu

    127.0.1.1 deek-ubuntu

    # The following lines are desirable for IPv6 capable hosts

    ::1 ip6-localhost ip6-loopback

    fe00::0 ip6-localnet

    ff00::0 ip6-mcastprefix

    ff02::1 ip6-allnodes

    ff02::2 ip6-allrouters

    ff02::3 ip6-allhosts

    still http://trial.127.0.0.1/wpmu/ is not displayed “Address not found is displayed” help !!!

    Avatar of Hudatoriq
    Huda
    Member

    @hudatoriq

    @dkbuddy:

    I suggest you reinstall your WPMU, install it in a domain, not subdirectory.

    Before installing, you need to prepare a domain and a directory to be used as the document root of the domain.

    1. Map your domain to the local IP in the hosts file.

    For example:

    127.0.0.1    mysite.dev
    127.0.0.1 blog1.mysite.dev

    2. Then you need to configure virtual host in your XAMPP installation. This way, XAMPP will use a specific directory to be used as the document root. Edit your apache configuration file. Usually it’s located inside your XAMPP installation (/opt/lampp). Add mysite.dev and use your WPMU installation directory as the docroot for mysite.dev

    3. Restart your Apache, and make sure XAMPP display the content of your WPMU directory when you visit mysite.dev in via your browser. When it’s OK, you can start installing WPMU.

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    That you ‘toriq’ from #buddypress? Howdy.

    :) ya i reinstalled and followed the steps carefully during installation now i can create new blog thanks for ur reply friend…

    Now how can i create a new user account in local host??

    Avatar of Hudatoriq
    Huda
    Member

    @hudatoriq

    @burtadsit

    Howdy, Burt. Yes, it’s me, :-)

    @dkbuddy

    Just create it. I think you also need to enable the apache mod_rewrite module, CMIIW.

    In your case without a dns name server, you need to add new lines in your hosts file whenever you add new blogs in subdomain.

    After i filled the registration form to signup as new user it says that “password is mailed to my ID(gmail ID)” but how can it be possible since i have installed WPMU and BP locally. whether any other way to get a new user account

    Ya i solved that new user problem too :)

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Having fun yet dkbuddy? mu just isn’t designed to operate on anything less than a real host with all the trimmings. Lots of little gotchas involved with anything less than that. It is possible but not pleasant.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.