Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem whit profilelink

  • Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    Hey

    I have a problem. When you clik on a users name on my site, it goes to sitename.com/USERNAME when it should go to sitename.com/members/USERNAME/profile

    How can I fix it?

    I use the newest version of Buddypress and WordPress.

    Thank you

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Did you add anything to use root profiles?

    Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    Yes. I was using Extended Profiles, bu after the last update it caused a lot of problems, so I deactivated it.

    Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    I tried to activate Extended Settings again and checked the Root profiles. Now the site sends me to sitename.com/USERNAME but the profile is placeed on sitename.com/username/profile.

    Anyone who knows how to fix this?

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    link?

    Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    To the site?
    I have found out, that there is to different problems.

    1. Extended Settings makes the profilepage crash
    2. The profile links in the activitystream is wrong. (It goes to juraportalen.com/username even when Extene Settings is deactivated)

    Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    The site is closed, but if you think it would help, I can create you an acount.

    Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    Is there anyone who knows how to fix this? It must be possible to chanke the links in the activitystream manually.

    I have created a user for those of you who wants to look around. I wold be really greathfull if someone could help.

    http://www.juraportalen.com

    User: Test
    Pass: testing

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Activity stream content is created / hard coded when the item is created, so you have your old member urls in there.
    You have two options.. A search and replace in your database of old style links, or add a filter to get activity item call which inserts the missing URL part.
    Unfortunately the activity stream items aren’t very resilient to future changes in URL structures.

    Avatar of Daniel Korfits
    Daniel Korfits
    Member

    @daniel-korfits

    Thank you, I will look in to it.

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Here’s a related thread — although, about post urls rather than member profile URLs, in the activity stream. http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/changing-wordpress-permalinks-breaks-old-buddypress-activity-updates-links/

    Storing the post URL independent of the permalink structure, is a simple enough fix. It’s harder to think of a solution that could deal with 3rd party plugins (or manual) changes to the member URL structure (other than the core BuddyPress being enhanced to support a ‘permalink’ settings for BP members / components similar to those applied by WP to posts, categories, etc.)

    Avatar of nitestop
    nitestop
    Participant

    @nitestop

    anyone else having a problem with the new buddypress update, public profile links are showing up as html code

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.