Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problem with the forum setup of a bbPress forum into BuddyPress

  • I installed bbPress into WordPress/BuddyPress site. Following the bbPress installation instructions, I uploaded bbPress into a folder and renamed it “forum.”

    I pointed my browser to the install page and filled out the three step form and all seemed to go well. I got an email from the bbPress installer stating that my installation was successful.

    This is my issue:

    In order to integrate bbPress into my WordPress/BuddyPress site, I need to use the “Forum Setup” option under the BuddyPress panel in the WordPress admin area. When I attempted to use the option offered to me labeled “Use an existing bbPress installation” I am asked for the location of my bb-config.php file. When I put in the path, I get this message:

    “The bb-config.php file was not found at that location, please try again.”

    I have tried using the path from the root of my server with and without using the actual bb-config.php file name.

    I have tried using the absolute path using my domain name with and without the file name above and with and without the “.www” in the path.

    I cannot think of any more possible ways to direct my site to know where bb-config.php is located. I can see it on the server and can open it. Nothing I can see is out of place.

    Anyone familiar with this issue? Thanks.

Viewing 11 replies - 1 through 11 (of 11 total)
  • It needs the file system’s absolute directory path, which you’ve already tried. Hmm. Assuming that the location and file actually exists, are they accessible by the web server? i.e. file or directory permissions.

    Hmmm, I see that bb-config.php is currently set to: 666 What should it be? I tried 644 didn’t work. I see the directory is set to 705. I tried 755 as per most WordPress logic. Tried it with the document inside being both 666 and 644.
    When you say absolute path do you mean literally to the system? it comes up with a path with all the directories up to the root of the server which I was surprised to see rather than the domain. But yes I tried all the possible paths I could think of .

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Are you trying to integrate an existing bbPress install with BP group’s? Or, is this a brand new bbPress install with no data?

    If the latter, there is no reason to do a separate install of bbPress. BuddyPress comes with a barebones version of bbPress already. It allows BP Groups to each have their own forums. However, it does not allow for the creation of a sitewide forum.

    If you have an existing bbPress forum that you’re trying to associate with BP, then the bbPress tables must be installed into the same database as your WordPress tables. Make sure that you have read this BP Codex article: http://codex.buddypress.org/buddypress-site-administration/using-an-existing-bbpress-installation/

    Finally, if you’re trying to have a standalone, global bbPress forum on your site, and not just have BP Group forums, then read this: http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/how-do-i-create-a-non-group-specific-forum

    I do see a possible problem here but don’t know enough about databases. I could get myself in way more trouble.

    I see in the bb-config.php file that my Table prefix is ‘bb_’ but in the bbPress installer log I see that the table prefix is ‘lh_’ (my wordpress table prefixes are set to ‘lh_’). This is what the log says:

    `>>> User database table prefix: lh_`

    Looking at my database I see that the prefix is bb_ could this be the problem and if so how would I fix it? I don’t see how i can rename those tables. or change the prefix. I’m just guessing here. Thanks.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Please see my first post in this thread as I may have been editing it as you were typing your response.

    As for your immediate post question above, the table prefix is not necessarily an issue (but it could be). It really depends on how you are trying to use bbPress (as a standalone forum, or solely for BP Group forums).

    But, to get to the heart of your issue, we need to clarify in what way you’re trying to use bbPress.

    Hi Jeff, I didn’t see your post before I made my last reply. OMG! I was over thinking this one.

    I didn’t realize that Buddypress had a copy of bbPress included in it. There is sort of a good reason for that but I won’t go into that part of my situation.

    Yes, I was thinking that I had to install the forum manually and then hook it up. My site is a BuddyPress site that I simply wanted to add a forum too much like this site. I wanted people who sign up for the site to have one login for a sitewide use including the forum.

    Sounds like I need to uninstall the forum–it has no data in it. If I uninstall this bbPress forum and remove those bb_ tables from my site database. Do I simply point the BuddyPress forum setup to my location? Thanks.

    The location didn’t come through on my post “ or
    “ ?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Your issue should be easy to fix!

    1. Before going through this process, double check to make sure that the bbpress directory exists under /plugins/buddypress/bp-forums/. It should be there as it comes with a clean install of BP.
    2. Assuming that checks out, then the next step is to make sure you have a backup of your MySQL database.
    3. Now delete, or in DB parlance, drop the unneeded bbPress tables from your database.
    4. Finally, go back to your WP admin screen and navigate to “BuddyPress > Forums Setup” and follow the instructions.

    Notes:

    There may be a meta record that tells BP that you’ve already installed bbPress. If BP thinks that a bbPress instance has already been installed, you’ll get some verbiage like the following:

    “bbPress forum integration in BuddyPress has been set up correctly. If you are having problems you can re-install”

    If that is the case, just click the “re-install” link.

    A successful bbPress install will have two bb-config.php files. The primary one will live at the root level of your WP install. The second one will be located at /plugins/buddypress/bp-forums/ and is a single one line piece of code to stop unauthorized access to your forums. It should not be an issue to delete the version living at the root level of your WP install as the process of installing bbPress for BP Group forum use creates this file. Do not delete the second, lower-level version of this file.

    THANKS so much! Yes, the directory does exist. I did the DB backup, removed the bb_ tables, ran the forum installer. Returning to the forum setup I see this:

    bbPress forum integration in BuddyPress has been set up correctly. If you are having problems you can re-install

    NOTE: The forums directory will only work if your bbPress tables are in the same database as your WordPress tables. If you are not using an existing bbPress install you can ignore this message.

    I also see the new tables in my database. What I don’t see is any forum control panel on my admin side or how to include a link to it in my site navigation. I’m looking around in the WordPress admin and on the visible site itself. What am I missing?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    You’re welcome! I’m glad you are up and running with BP Group forums.

    With respect to a forum control panel in WP’s back end, you are not missing anything. When using bbPress as a BP Groups forum component, there is no sitewide bbPress admin control. Instead, each BP group has the ability to have its own forum. To get the group forums to work, a group admin has to navigate to the given Groups “Admin > Group Settings” menu and click the “Enable discussion forum” checkbox.

    Thanks again Jeff. I have a feeling that my audience won’t use this forum because it is a bit of a thinker for the uninitiated but at least its in place and I know its working. I had hoped to put the link to the forum in my nav bar and offer text links throughout the site but with this group mentality not sure how to proceed. Do you have any links to sites that might be good examples to emulate? My site is an alumni site not that the example needs to be an alumni site. Thanks again you saved my bacon!

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.