Skip to:
Content
Pages
Categories
Search
Top
Bottom

Problems logging in BP in IE

  • Avatar of jmonroe
    jmonroe
    Participant

    @jmonroe

    I have a BP site that I and other members can login to if we are using Firefox, Chrome, or Safari but IE just refreshes the page and gives you the same login page as when you first go to the site. Does anyone else have this issue? I tried this solution that I found worked for a different kind of php site I was having difficulty logging into with IE. That site is resolved. (link for solution) http://adamyoung.net/IE-Blocking-iFrame-Cookies

    Any help is greatly appreciated so I can get the members up and going without restricting them from using IE.

    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of jmonroe
    jmonroe
    Participant

    @jmonroe

    Update….I was reading the code on the wp-login.php page and noticed that the code is set that if cookies are disabled to not login even with a valid user and password. I went into IE and set my machine to allow third party cookies…and Voila! I was able to login. Does anyone know of a workaround for this? I know I can enable cookies in the security settings in IE however, I cannot control everyone elses browser. I would like to modify the code if possible so that it works on everyones IE browser. The code is below….

    // If cookies are disabled we can’t log in even with a valid user+pass
    if ( isset($_POST) && empty($_COOKIE[TEST_COOKIE]) )
    $errors->add(‘test_cookie’, __(“ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.”));

    I am also having the same problem but this time it is in firefox, this isn’t good as most don’t even know what cookies are yet alone how to enable or disable them.

    I need a work around, can i just remove this check? is it mandatory for buddypress to use cookies to function? what are the risks of disabling this feature?

Viewing 2 replies - 1 through 2 (of 2 total)

The topic ‘Problems logging in BP in IE’ is closed to new replies.