Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] BuddyPress and bbPress: ”You do not have sufficient permissions to access this page.”

  • Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    I installed a fresh copy of WordPress Multisite (3.3.2) and added the BuddyPress plugin (1.5) and Network Activated it. This is sub domain install.

    On the primary site I configured BuddyPress and then clicked the “Install Group Forums” button and received the error “You do not have sufficient permissions to access this page.”

    Any thoughts on what I can look for?

    @elangley

    ~eric

    Configuration
    1. Which version of WordPress are you running?
    3.3.2
    2. Did you install WordPress as a directory or subdomain install?
    Subdomain
    3. If a directory install, is it in root or in a subdirectory?
    root
    4. Did you upgrade from a previous version of WordPress? If so, from which version?
    fresh install
    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.
    Not applicable, fresh install
    6. Which version of BP are you running?
    1.5.5
    7. Did you upgraded from a previous version of BP? If so, from which version?
    No
    8. Do you have any plugins other than BuddyPress installed and activated? If so, which ones?
    No
    9. Are you using the standard BuddyPress themes or customized themes?
    Standard BuddyPress Theme
    10. Have you modified the core files in any way?
    No
    11. Do you have any custom functions in bp-custom.php?
    No
    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    bbPress 2.0.2 (Installed it after the setup link did not work.
    13. Please provide a list of any errors in your server’s log files.
    14. Which company provides your hosting?
    EC2 virtual private server
    15. Is your server running Windows, or if Linux; Apache, nginx or something else?
    Bitnami WordPress WIndows Stack (xAMP)

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    @mercime

    Hopefully you can help me. bbPress seems foundational to the BuddyPress experience….

    @elangley

    Hmm.

    Are you accessing the forums page on the site’s admin screens, or the network admin screen? It ought to be the latter in a multisite config.

    Avatar of Eric Langley
    Eric Langley
    Participant

    @elangley

    I had enable BP multi blog enabled in wp-config, thus BuddyPress is automatically activated and configured at the site level.

    I went ahead and dis-enabled BP multi blog and this put the BuddyPress control panel in the Network Admin site. There I was able to configure bbPress so that it worked.

    Then I enabled BP multi blog and added sites. I now have separate bbPress forums on each site with the addition of BP Multi Network filtering.

    ~eric

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.