Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Profile name field doesn’t change after upgrading 1.5.1 to 1.5.4

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Are you trying to change the name of a profile field? Or change your username?

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    I’m trying to change the name field of extended profile. But it always shows the username instead. This didn’t happen on 1.5.1, but started right after I upgraded to 1.5.4.

    I also tried selecting both yes and no a few times on the configuration where it asks to sync wordpress profile to buddypress, but this didn’t solve the problem yet.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Your response still doesn’t help clarify the issue. I need to know if you are attempting to edit a user’s profile, or a specific field in the XProfile component in wp-admin.

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    FYI, I downgraded BP versions and results are followings (WP 3.3.1)

    BP 1.5.3.1 – not working, same error remains
    BP 1.5.2 – not working, same error remains
    BP 1.5.1 – not working, same error remains

    But my previous version was 1.5.1 and was fully working, so I’m thinking this was caused by WordPress core itself, not BuddyPress. I’m going to test by downgrading WordPress core.

    As John asked, are you attempting to edit a user’s profile, or a specific field in the XProfile component in wp-admin?

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    As I’ve been saying, I can’t edit the name field of extend profile since I upgraded WordPress and BuddyPress. And results are as above. I suggest dev teams respond to the bug report I mentioned in the first post, too. My problem is the same as he/she reported.

    I’ll let you know after I check with older ver. of WordPress.

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    I’ve downgraded WordPress 3.3.1 to 3.2.1 with BuddyPress 1.5.1. Unfortunately the problem still happens the same way when I upgraded WordPress and BuddyPress to the latest versions.

    I don’t know what else is causing the problem, but if I solve I’ll post again.

    Avatar of Cyrille13
    Cyrille13
    Member

    @cyrille13

    Hello,
    I think i have the same issue. With Wp 3.3.1, BuddyPress 1.5.4 and bbPress 2.0.2, when a user try to edit his profile, the nickname is deleted. I try to deactivate all my plugins and change to bp-default theme and no difference. I have no proble with the wp-admin.
    Regards,
    Cyrille

    Avatar of Cyrille13
    Cyrille13
    Member

    @cyrille13

    i solved my problem with updating the initial bp_xprofile_field (nickname) in wp-admin….
    I hope this solution is good for you too.
    Regards,

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    @cyrille13 Your advice solved the problem. Thank you so much!

    So…dev teams, do you think this is a bug?

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I’m perplexed that you understand each other and I am still not confident what the problem is or how either of you have fixed it.

    Not clarifying the issue with clear and concise steps to reproduce it is leaving the dev team without an understanding of how to duplicate; there is no way to fix something we do not understand.

    I’m closing this topic since it seems resolved. If you are able to include clear steps to reproduce this (go here, click here, this happens, go here, this happens, etc…) please drop them in the ticket you linked to above.

    Avatar of Boone Gorges
    Boone Gorges
    Keymaster

    @boonebgorges

    Hi @takuya and @cyrille13 – Sorry for some of the miscommunications above. It was only after seeing the linked bug report that I was able recognize that what you were reporting was actually an instance of http://buddypress.trac.wordpress.org/ticket/3725, which we’ve known about for a while, but which was very difficult to track down. (See http://buddypress.trac.wordpress.org/ticket/3725#comment:7 for all the gory details.) It has been fixed for the next version of BP. In the meantime, you can fix your installation either by manually applying http://buddypress.trac.wordpress.org/changeset/5778, or by doing what @cyrille13 suggests: changing the name of your Full Name profile field at Dashboard > BuddyPress > Profile Fields.

    Thanks for your patience.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.