Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] RSS Error

  • Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    http://blog.skemaholicsanonymous.com/feed/

    This page contains the following errors:

    error on line 4 at column 6: XML declaration allowed only at the start of the document

    When I deactivated Buddypress the RSS worked.
    Re-activated Buddypress and it broke again.

    1. Which version of WordPress are you running?
    3.5.1

    2. Did you install WordPress as a directory or subdomain install?
    subdomain

    3. If a directory install, is it in root or in a subdirectory?

    4. Did you upgrade from a previous version of WordPress? If so, from which version?
    Not sure

    5. Was WordPress functioning properly before installing/upgrading BuddyPress (BP)? e.g. permalinks, creating a new post, commenting.
    Yes

    6. Which version of BP are you running?
    1.7.2

    7. Did you upgraded from a previous version of BP? If so, from which version?
    Not sure

    8. Do you have any plugins other than BuddyPress installed and activated?
    Yes

    9. Are you using the standard BuddyPress themes or customized themes?
    2012

    10. Have you modified the core files in any way?
    Added Style to member-header.php

    11. Do you have any custom functions in bp-custom.php?
    yes`function remove_xprofile_links() {
    remove_filter( ‘bp_get_the_profile_field_value’, ‘xprofile_filter_link_profile_data’, 9, 2 );
    }
    add_action( ‘bp_init’, ‘remove_xprofile_links’ );`

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?
    2.3.2

    13. Please provide a list of any errors in your server’s log files.

    14. Which company provides your hosting?
    hostmysite.com

    15. Is your server running Windows, or if Linux; Apache, nginx or something else?
    Linux

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    Solved by deleting and re-installing.

    Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    It’s back, but with a different message:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://blog.skemaholicsanonymous.com/feed/
    Line Number 4, Column 1:<?xml version="1.0" encoding="UTF-8"?>
    ^

    Again, not sure what I did but it seems to be me breaking things.
    Possibly because I am adding new plugins.

    Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    Solved in same way. Deleted via ftp reinstalled via plug in menu.

    Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    Ok, haven’t played with plug-ins and the error is back. :(
    All I did was add a new post.

    Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    Ran through http://validator.w3.org/feed/ with buddypress disabled and it was valid.
    Ran through with buddypress enabled and got this:

    Sorry

    This feed does not validate.

    line 1, column 1: Blank line before XML declaration

    If I knew where the white space was I would delete it, but I’m lost here. :(

    Avatar of angelladesigns
    angelladesigns
    Participant

    @angelladesigns

    Resolved!
    Operator error.
    bp-custom.php had the white space.

    Avatar of akukskuks
    akukskuks
    Participant

    @akukskuks

    I think I’m having the same problem but you seem to have far more server-end know-how than I do, so if you were lost…

    Any advice or head start you can give me and the lucky IT guy I find to help me find out why all the RSS feeds are broken (dashboard and front-end)? Looking for white space in bp-custom.php?

    Avatar of @ubernaut
    @ubernaut
    Participant

    @ubernaut

    bp rss feeds can definitely be erratic, we are working on it:

    http://buddypress.trac.wordpress.org/ticket/5020

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.