Skip to:
Content
Pages
Categories
Search
Top
Bottom

set wmode=”transparent” for oembed plugin

  • Avatar of abu_eldahab
    abu_eldahab
    Member

    @abu_eldahab

    Hello,

    I’m using oEmbed for BuddyPress plugin i want to add wmode=”transparent” to solve flash z-index problem how can i do that ?

    Regards

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    If you are wanting to ensure that the flash object actually sits as part of the page you will want wmode=”opaque” rather than ‘transparent’.

    Adding this attribute is not that straightforward, Rays plugin uses the WP oembed class and a quick glance at that doesn’t reveal a simple approach to adding this attribute and I’m finding the markup construction rather fractured to follow however there appears to be filters that could be used.

    I think a shoutout to @r-a-y might be in order as he will probably know how to feed a new attribute to the object tag – if it proves not feasible the only solution I could think of would be to inject the attribute using jQuery but it wouldn’t be the best approach.

    Avatar of abu_eldahab
    abu_eldahab
    Member

    @abu_eldahab

    Hello ,

    Thanks for your replay , as a temporary solution i solved it with jquery by using this code

    jQuery(‘embed’).attr(‘wmode’,’Opaque’).wrap(‘

    ‘);
    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    There’s a filter you can use: embed_oembed_html.

    Do something like this:
    http://pastebin.com/SnfW14ZC (updated, previous one had a typo)

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    opaque!

    Avatar of abu_eldahab
    abu_eldahab
    Member

    @abu_eldahab

    @r-a-y

    i tried to do as you said and it gave me error
    “Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘my_eombed_wmode’ not found or invalid function name in /home/wp-includes/plugin.php on line 166″

    Avatar of Pisanojm
    Pisanojm
    Participant

    @pisanojm

    @r-a-y I got the same error as abu above when adding snipet to the functions.php re: transparent oembed

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    @pisanojm @abu_eldahab – There’s a typo on the last line.

    Change “my_eombed_wmode” to “my_oembed_wmode” and it should work.

    *Edit – I just noticed that there’s an error in my code. Updated Pastebin snippet should work now.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.