Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Site broken after WP 3.5 update

  • Avatar of deannadares
    deannadares
    Participant

    @deannadares

    Hello: I’m not a programmer and have been loving the ease of BuddyPress–until today, when I clicked a button to update to the latest version of WP 3.5! We’re running BP version 1.6.1 at modpo.org.

    I can access the Dashboard but nobody can log in. We now have three error messages at the top of every page:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/broadscasting/modpo.org/wp-content/plugins/buddypress/bp-core/bp-core-functions.php on line 176 and defined in /home/broadscasting/modpo.org/wp-includes/wp-db.php on line 990

    I updated WP before updating any of my plug-ins, including BP. I have deactivated all plug-ins except BP without any change in situation, that I can tell.

    Can anyone tell me what went wrong, and how to fix it?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of @ubernaut
    Ben Hansen
    Participant

    @ubernaut

    it hunk you need to be on 1.6.2 for 3.5 compatibility.

    Avatar of Blogurp
    Blogurp
    Participant

    @blogurp

    I had those same three errors on my test site, nky.mobi. Like Ben said, I had to upgrade to BuddyPress 1.6.2, after getting WordPress 3.5. I then had to get rid of name availability checker plugin from BuddyDev through my FTP client because the site would not work with it. Then, I had to manually network activate BuddyPress through network admin because for some reason it was not network activated. After that, everything came back fine. Could only access dashboard there too cause BuddyPress was not activated.

    Avatar of deannadares
    deannadares
    Participant

    @deannadares

    Thank you both! Now I’m wondering how I can update BP as I can’t do anything on my Dashboard — I have to delete and add the BP update to the server files via FTP, right? There is a plug-in file and I would delete anything named BuddyPress before uploading the new BP files? Where do I get the actual files? I’ve only ever just pressed the download button from the WP Plug In “store”!

    Avatar of @ubernaut
    Ben Hansen
    Participant

    @ubernaut

    sounds a bit extreme to me but if the only way you can access is by renaming or deleting the plugin folder then i suppose that’s what i would do.

    Avatar of Blogurp
    Blogurp
    Participant

    @blogurp

    I’m guessing your site is a regular single WordPress install with BuddyPress plugin? You can’t get to your dashboard via modpo.org? I just went to modpo.org/wp-admin and it showed for a second then it went away. If you are using one of those hosting companies with one press WordPress install, they might not let access to modpo.org/wp-admin. I just went to modpo.org/wp-login and it came up as a 404 error page not found, but, it shows the login for your site. See if you can login there. If you can login there, then you should be able to get to your dashboard, if you have login set to take you to your dashboard. If you can, then you can deactivate BuddyPress there, and then upgrade or just upgrade. Plugins do not have to be activated to upgrade, just installed. If none of that works, then I would say you would have to get rid of the BuddyPress plugin via FTP to access your site, then reinstall the new version, or, you can do it through your hosting company where you can access your files in your root directory.

    It looks like 1.6.1 is only available here, but, 1.6.2 will be available in your dashboard as an upgrade, but if you can’t get to that, I’m not sure where you can get 1.6.2 yet.

    Avatar of deannadares
    deannadares
    Participant

    @deannadares

    blogurp, bless you!!!! I had tried to activate another plug-in and it didn’t work, but this time, I just clicked on the Update Now for BuddyPress from the Plug-Ins area of the Dashboard, and it removed the old BP and updated the plug-in and installed successfully. No more error code! All of the posts seem to be there. Whew. Now I have to activate plug-ins one by one and hope nothing breaks again with 3.5.

    Thank you SO MUCH for your help and quick responses!!!

    Avatar of Blogurp
    Blogurp
    Participant

    @blogurp

    Anytime :) I haven’t found any plugins that break it, but BP Gallery Plus, doesn’t work right with it yet.

    Avatar of deannadares
    deannadares
    Participant

    @deannadares

    OK I will watch out for that one…thanks again!

    Avatar of deannadares
    deannadares
    Participant

    @deannadares

    And Ben, thank you for getting me on the right track with the BP/WP version conflicts — you saved me hours of work figuring it out!

    Avatar of @ubernaut
    Ben Hansen
    Participant

    @ubernaut

    glad to be a help

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.