Skip to:
Content
Pages
Categories
Search
Top
Bottom

Sitewide activity not refreshing when deleting blogs

  • I’ve ran into an issue (running WPMU 2.7.1 and BP 1.0 with subdomains, everything working as it should) with the sitewide activity widget. Did some imports of other blogs to play around, and then deleted them, but the blog posts are still in the activity wire. This means that the sitewide activity isn’t refreshing properly.

    How can I force the sitewide activity wire to refresh on a regular basis? Is it possible to setup a cronjob for this to make sure deleted content gets purged from the sitewide activity?

    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Giving this a tiny little bump. No one seeing this problem? Got a solution?

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Yes it’s possible to cronjob this, but you shouldn’t need to.

    There are a few instances where the activity feeds aren’t refreshed, and my guess is that deleting blogs may be one of them (since it happens so rarely, and usually removing something isn’t reported.)

    Example being that when you remove a friend, it doesn’t appear on your activity stream, etc…

    Right. So whenever someone deletes a blog I need to do something that refreshes the activity feed, correct? Is there a list of these things somewhere?

    Avatar of Dbascent94
    dbascent94
    Participant

    @dbascent94

    Thord,

    If you are comfortable with phpmyadmin you can delete the individual entries from the database.

    Yes, of course. Problem is, no one will be able to do that when I’m not around so a cron solution would perhaps be preferred. Or more frequent checks against what goes in the activity stream at least.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.