Skip to:
Content
Pages
Categories
Search
Top
Bottom

Still no Avatar fix?

  • Avatar of Vast HTML
    Vast HTML
    Participant

    @erichamby

    I have just moved to TMD hosting for thier great buddypress support. however now that i have moved to what i hear is the “best” buddypress host uploading avatars still will not work when creating an account or creating a group. The only way to get an avatar is to go back later in settigs and upload one.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Which versions of WPMU and BuddyPress are you running?

    Avatar of Vast HTML
    Vast HTML
    Participant

    @erichamby

    WPMU: 2.7.1

    BP: 1.0 RC2

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Do you have any other plugins besides BuddyPress installed? Do you receive any error messages?

    Have you read this post? http://buddypress.org/forums/topic.php?id=2190#post-11864

    Avatar of Vast HTML
    Vast HTML
    Participant

    @erichamby

    When trying to upload whe creating a new account no errors appear. When uploading creating a group error 500 shows

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    When uploading creating a group error 500 shows

    Okay, so your server is throwing an Error 500–Internal Server Error.

    A few more questions:

    • Which hosting company are you using?
    • Is your site running PHP 4 or PHP5?

    There are a few additional steps that can be taken–increasing the memory limit in php.ini and forcing Apache to run PHP 5, assuming that it is not.

    I’m actually going to get some sleep now. So, please reply and if someone else reads this before I do tomorrow, perhaps they’ll continue helping you.

    Good luck! I\’ll check back.

    Avatar of Vast HTML
    Vast HTML
    Participant

    @erichamby

    Using TMD hosting with PHP 5.

    http://crowzero.com is the site.

    Thanks for the help :)

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Okay, so you’re site is running PHP5. I’m guessing that what is happening then is a PHP is running into a memory limit. So, we’re going to help PHP by boosting its memory limit.

    You’ll need to make a file called php.ini. Inside this new file, put this:

    memory=48MB

    Once you’ve created that file, upload it to your wp-admin directory.

    On some installs, I’ve had to boost the memory to 96MB. If 48MB does not work, try increasing.

    Let me know how that goes.

    Avatar of Nicola Greco
    nicolagreco
    Participant

    @nicolagreco

    how are your permissions in wp-content/blogs.dir ?

    check if permissions are 777 and the user & the group is not root:root

    Avatar of Hyrxx
    hyrxx
    Participant

    @hyrxx

    just a quick question, what is this memory limit thing

    i know it prevents me from uploading big images etc, but what is it actually refering to?

    the chunk of memory allocated to the script at runtime? ie is this just space in ram for php to use?

    Avatar of Vast HTML
    Vast HTML
    Participant

    @erichamby

    Thanks guys it worked perfect.

    Only 234234 more things to fix now.

    Group forums dont work at all.. keep getting an error when trying to post. The email notification have html tags in them, and i got to figure out how the heck to import my users from a regular wordpress install.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @Erichamby-

    Wait!

    I’m glad it worked, but you need to do two things:

    1. Say what was the solution

    2. Turn on the green light –the topic is solved!

    Good luck with the other 235k things!

    Avatar of Vast HTML
    Vast HTML
    Participant

    @erichamby

    Changed permission to 777 and uploaded a php.ini file has was suggested. I didnt do one at a time so sorry i dont know if it was one or both that did the fix.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Thanks for the info–and setting this thread to green!

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.