Skip to:
Content
Pages
Categories
Search
Top
Bottom

The requested URL /groups/ was not found on this server.

  • Hi everybody,

    Get some message after clicking at menues “Groups” and so on. The requested URL /groups/ was not found on this server.
    After installing buddypress there is nothing “behind” the menus “Activity”, “Members” and so on.
    Installed Buddypress 1.2.4 with wp 3.0.1 (see “www.familie-stracke.net”). Did nothing else (no groups, forums etc. installed). Theme is default.
    Multi site and german speech also installed; but didn’t even work without multi site or with original speech.
    Any idea?
    Thank’s for any hint! Thomas

Viewing 25 replies - 1 through 25 (of 40 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    ? BP 1.2.4 you need to install 1.2.5.2

    If you have really installed 1.2.4 try upgrading it to 1.2.5 and see if that makes a difference and report back.

    Avatar of Thorsten
    Thorsten
    Participant

    @per4mance2

    I’ve the same problem. After I changed the permalinks to ‘/index.php/%category%/%postname%/’ for running buddypress there is nothing behind ACTVITY, MEMBERS, GROUPS. I run a complete new WP 3.0.1 with buddypress 1.2.5.2. There is no Guide after the installation of the buddypress plugin. What’s wrong?

    Thanks for help!

    Avatar of umberrella
    umberrella
    Member

    @umberrella

    Yes, I run into this problem too. I used the plugin to make my theme compatible with bp. and step 1 was succeeded, files were moved. Then I could go to step three. There it tells me to check links under “my account”. nothing works. :(

    Avatar of umberrella
    umberrella
    Member

    @umberrella

    hmm I noticed… the urls point to: the-url.com/members/admin/activity/ while that plugin have moved the members folder into my theme folder. I think this moving did not go as it should be?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    People The community , must as a whole, stop this practice of hijacking threads we now have three questions running in the same thread this practice isn’t tolerated on most tech forumsd due to the confusion that thread dissolves into.

    The first thing all three of you must check is that your permalinks are working correctly and that the server can write to the .htaccess file

    Avatar of Thorsten
    Thorsten
    Participant

    @per4mance2

    Hi … more information I need, because I wrote above that the problem still exists.

    See my first Buddypress http://www.unitedcasting.de/ please. BuddyPress did not created directories or files for ‘acitivity’, ‘members’ or ‘groups’. I use Windows 2003 R2 Server in English with MySQL 5.1.46, PHP 5.2.13, WP 3.0.1 and BP 1.2.5.2. All WP Blogs work fine without any problems. Why does Buddypress do not work as it should? Where are the files behind the directories of BP? Does the BP plugin need special rights?

    Thanks for help!!!

    Sorry, I was mistaken. My bp-version infact IS 1.2.5.2.
    But I cant’ find any .htaccess-file (Cyberduck-Options is to _show_ any “.”-files.) Neither can’t find any with my provider’s explorer-tool, too.
    Did start some trouble-ticket to my provider, will wait what he tells me. Wasn’t shure wether I should create any such files and what to write in.
    Thank’s for feedback! Thomas

    Avatar of Thorsten
    Thorsten
    Participant

    @per4mance2

    Ok, I found one hint in Buddypress German Forum of WordPress, see http://forum.wordpress-deutschland.org/buddypress/73994-seite-nicht-gefunden-members-usw.html

    I post there a solution for the normal menu. The ‘index.php’ file is missing in the permanent structure, maybe there is something different between the WP English and WP German version of 3.0.1. So all of you have the URL http://www.yourdomain.com/groups/. Please change it in your Browser to http://www.yourdomain.com/index.php/groups/ and check if you’ll get a page. Change ‘yourdomain.com’ in your real domain. See my page http://www.unitedcasting.de/index.php/groups/ – it works.

    But now I’ve to search for the links under ‘MyAccount’ and ‘Notifications’. Maybe someone knows where the file is safed. Thanks.

    Avatar of umberrella
    umberrella
    Member

    @umberrella

    yes, this seems to work Thorsten. I’ll search with you for how to adjust that links under “myaccount”and “notifications”

    @hnla both checked. work.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    @strackus you need an .htaccess file. What happens when you change permalink settings? change them to another setting and report any messages seen on the screen about creating/writing to the file. You shouldn’t have to create the file but your server must be able to write and read to this file. What server are you running on? not IIS by any chance?

    Avatar of Thorsten
    Thorsten
    Participant

    @per4mance2

    Ok Guys! I found the solution for IIS Server! There is a problem with the ‘mod_rewrite’ function, it does not work. Here is the solution and I tried it and it works. Please take a look at http://www.kylecaulfield.com/permalink-for-wordpress-iis-6-mod_rewrite-fixed-free

    The result of my new Buddpress can be viewed here http://www.unitedcasting.de/

    Sorry for the try above, but it’s no really good solution, so I switched into the original theme file of Buddypress theme.

    Many hours today for this result and nobody knewed that. Maybe a problem of Windows worker like me ;-)

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    @Thorsten that also worked for me…
    When using buddypress how do you change it so when you click on “my account”, or any link for that matter, it calls out http://www.yourdomain.com/index.php/groups/ Mine is still defaulting to http://www.yourdomain.com/groups/ even though I changed the permlink settings in my wordpress dashboard

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @christinarule : unfortunately, I don’t know how to set your links to include index.php, but confused why you would want that? Without the index.php will give you better search engine performance, as well as being more human readable

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Ditto what roger says. Adding the index.php path part into the url is only something I’ve seen in reference to the ‘Almost Pretty Permalinks’ There is no reason to want this really; it certainly will not aid search engines.

    If you must do this have you tried writing a custom permalink structure? never tried this myself as never seen the need, with the prebuilt options available.

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    Well the only reason I was setting my permalinks to /index.php/%category%/%postname%/ was because if I didnt ( if i would just set them to /%category%/%postname%/) then my whole site would break… I couldnt click on any other page with out getting a “not found” error.

    Even when I set my perma linking to /%category%/%postname%/ my buddy press still goes to a “not found page”

    Am I missing something??

    I thought maybe updated my wordpress would do the trick so thats what I did last night… and still nothing… in fact now im just left with an even MORE broken site. I guess some of my plug ins arent working correctly with wordpress latest version.

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    here is a visual…incase it makes more sense http://christinarule.com/bperror.jpg

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    Thanks in advance

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    I think there is something wrong in your basic install / wp-config.php / .htaccess setup. I’m surprised to see your blog pages have index.php in the url, even though you’ve set /%category%/%postname% as the custom structure.

    I suspect the problem is not in BuddyPress, but perhaps in the basic underlying install structure.

    Unfortunately, I’m not an expert on fixing this though. Anyone else able to help?

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @christinarule – if you post your .htaccess and wp-config.php files (use pastebin.com). It might help pinpoint the problem.

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @christinarule – also, do you have anything in the category base field on the permalink page?

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    .htacess

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    wp-config:

    <?php
    /**
    * The base configurations of the WordPress.
    *
    * This file has the following configurations: MySQL settings, Table Prefix,
    * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
    * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
    * wp-config.php} Codex page. You can get the MySQL settings from your web host.
    *
    * This file is used by the wp-config.php creation script during the
    * installation. You don’t have to use the web site, you can just copy this file
    * to “wp-config.php” and fill in the values.
    *
    * @package WordPress
    */

    // ** MySQL settings – You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define(‘DB_NAME’, ‘***’);

    /** MySQL database username */
    define(‘DB_USER’, ‘***’);

    /** MySQL database password */
    define(‘DB_PASSWORD’, ”);

    /** MySQL hostname */
    define(‘DB_HOST’, ‘localhost’);

    /** Database Charset to use in creating database tables. */
    define(‘DB_CHARSET’, ‘utf8′);

    /** The Database Collate type. Don’t change this if in doubt. */
    define(‘DB_COLLATE’, ”);

    /**#@+
    * Authentication Unique Keys.
    *
    * Change these to different unique phrases!
    * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/ WordPress.org secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    *
    * @since 2.6.0
    */
    define(‘AUTH_KEY’, ‘put your unique phrase here’);
    define(‘SECURE_AUTH_KEY’, ‘put your unique phrase here’);
    define(‘LOGGED_IN_KEY’, ‘put your unique phrase here’);
    define(‘NONCE_KEY’, ‘put your unique phrase here’);
    /**#@-*/

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = ‘wp_’;

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to ‘de’ to enable German
    * language support.
    */
    define (‘WPLANG’, ”);

    /* That’s all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined(‘ABSPATH’) )
    define(‘ABSPATH’, dirname(__FILE__) . ‘/’);

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . ‘wp-settings.php’);

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    @ roger…”also, do you have anything in the category base field on the permalink page?”

    I really am not 100% sure.. I just was sopse to be the designer… I paid a developer back in May and he still hasnt finished it and wont contact me… (awesome!)

    I appreciate your help….

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    also just realized i didnt use paste bin correctly… Im sorry!

    Avatar of christinarule
    christinarule
    Member

    @christinarule

    I also should note that in this image http://christinarule.com/bperror.jpg the image on the right…if I click on a buddypress link its takes the index.php out of the URL but if I add it in myself then it works… maybe I need to somehow make it put in the index.php idk how else id do that since Im already doing that in the permalink setting

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    @christinarule -

    other than the check for mod_rewrite.c, you have the same .htaccess that I have in a default install, with permalinks set to /%category%/%postname%/ (http://playground.21inspired.com is a simple default install).

    My .htaccess:
    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Unfortunately, this is beyond my area of expertise. Hopefully, someone else can help you get rid of index.php in your urls, and get the blog & BuddyPress urls resolved correctly.

    Other quick thoughts: is your .htaccess in your site’s root directory? Do you have other .htaccess files in the subdirectories? Does your server support mod_rewrite?

    Anyone able to help?

Viewing 25 replies - 1 through 25 (of 40 total)

The topic ‘The requested URL /groups/ was not found on this server.’ is closed to new replies.