Skip to:
Content
Pages
Categories
Search
Top
Bottom

Theme/profile errror, even with themes correctly installed

  • Avatar of Jfcarter
    jfcarter
    Participant

    @jfcarter

    I have triple-checked my themes and they are in the correct folders, but when I click on a member to see their profile, I get the message below:

    Warning: require_once (/wp-content/member-themes/buddypress-home/index.php) [function.require-once]: failed to open stream: No such file or directory in /wp-includes/theme.php on line 822

    Fatal error: require_once() [function.require]: Failed opening required ‘/wp-content/member-themes/buddypress-home/index.php’ (include_path=’.:/usr/local/share/pear’) in /home/u2/zaifv9sjbm/cloudwomen.com/html/wp-includes/theme.php on line 822

    Thanks for your help.

Viewing 21 replies - 1 through 21 (of 21 total)
  • Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    Make sure the permissions are set to 644.

    Avatar of Jfcarter
    jfcarter
    Participant

    @jfcarter

    1) Permissions are fine.

    2) What about the fact that the path doesn’t exist?

    /wp-content/member-themes/buddypress-home/index.php

    This isn’t even a location! Do I need to redefine a function or something?

    I had this exact same error. I realised that I had put the member-themes folder in wp-content/themes instead of directly into wp-content. Works fine now.

    Avatar of Jfcarter
    jfcarter
    Participant

    @jfcarter

    Thanks, but member-themes is located in wp-content.

    Anyone else have any ideas?

    Avatar of MartinNr5
    MartinNr5
    Participant

    @martinnr5

    Looking at the path you’re posting above (/wp-content/member-themes/buddypress-home/index.php) it seems as if you’ve selected the BuddyPress home theme as the default theme for your member pages and not the actual member theme.

    I’m not sure how you’d be able to do that though.

    What are the contents in your “member-themes” folder?

    Avatar of Jfcarter
    jfcarter
    Participant

    @jfcarter

    @MartinNr5,

    That’s the mystery. My member-themes folder contains a directory called ‘buddypress-member’ and that’s it.

    I don’t have a buddypress-home folder there.

    I think there is a function that is defined to look for a file here: /wp-content/member-themes/buddypress-home/index.php

    but cannot, because the location doesn’t exist.

    I’m wondering where this function is and how to redefine it.

    Jessica

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    From what I can gather this thread is about a configuration problem. This is how to install the two themes.

    1) From the distribution zip or trunk move the folder /buddypress-theme/buddypress-home to the folder /wp-content/themes. You wind up with the structure /wp-content/themes/buddypress-home

    2) Move the folder /buddypress-theme/member-themes to the folder /wp-content. Ending up with the structure /wp-content/member-themes.

    If you want to use the bp home theme then you need to activate that in wpmu backend. You will never see the member theme as a possible candidate to activate.

    Avatar of Jfcarter
    jfcarter
    Participant

    @jfcarter

    @burtadsit,

    Thanks for your post. My files are already exactly as you suggested; I paid careful attention in the install instructions.

    I already activated the bp home theme in the WPMU backend.

    I think what’s happening is a function needs to be changed to reflect the new location of buddypress-home and member-themes.

    In the meantime, I’ve figured out a workaround.

    Hi,

    I have the exact same error with the latest release of buddypress and wp 2.7, and just as jfcarter explained my templates are also in the correct directories with the correct permissions. The system looks for “buddypress-home” instead of “member-themes”

    wp-content/member-themes/buddypress-home/index.php) [function.load-template]: failed to open stream: No such file or directory in /wp-includes/theme.php on line 822

    Avatar of Jfcarter
    jfcarter
    Participant

    @jfcarter

    I have a sketchy workaround. I duplicated the buddypress-member directory and named it buddypress-home. I put them both in the member-themes directory. And now it works perfectly!

    Avatar of Alainhc
    alainhc
    Member

    @alainhc

    Hi. I had the same problem with buddypress, and i had to to what jfcarter suggested: duplicating the buddypress-member directory and naming it buddypress-home. But I think must be a better solution. Anyone knows which version of buddypress doesn´t have that problem?

    Alain

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    I think there must be some confusion as to the proper location of themes. See:

    http://codex.buddypress.org/getting-started/using-the-buddypress-themes/ for an overview.

    You shouldn’t have to rename directories if everything is in the right spots.

    Avatar of Alainhc
    alainhc
    Member

    @alainhc

    burtadsit, there´s no confusion on the proper location of themes. You can try to install the last release of buddypress and wp mu 2.7 and you´ll see the error.

    Thanks to jfcarter for giving one solution.

    Alain

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Hi people. The combo download for RC-1 from buddypress.org is fine in both the zip and tar.gz versions. Everything is where it should be. Just checked.

    When does this happen? Clean install, activate the home theme visit the root blog and then you get this error? Or does this only occur when you are in the member theme area such as your profile and then try to visit the home theme? For example you click ‘blog’ or ‘members’ buttons.

    I think that something is trashing a WP constant called TEMPLATEPATH that is created in wp-settings.php >> define(‘TEMPLATEPATH’, get_template_directory());

    It’s either not getting set correctly or it’s getting fubar’ed later, somehow.

    Have you tried activating a different theme for the root blog? Do you get the same error? Try just activating *anything* else other than the bp home theme and then do what you did to reproduce the problem.

    Trying to narrow things down. Lemme know.

    p.s. I flipped the red light switch on this thread so that others may join in the fun too.

    Avatar of Alainhc
    alainhc
    Member

    @alainhc

    Hello everyone. Hi Burtadsit. I´ll try to explain using my poor English, I´m cuban. The error occurs in a Clean install, when you activate the home theme and try to visit the root blog, or the blog of any user previously created.

    The page show the following error:

    Warning: require_once(C:sitiossitiosocial/wp-content/member-themes/buddypress-home/index.php) [function.require-once]: failed to open stream: No such file or directory in C:sitiossitiosocialwp-includestheme.php on line 822

    Fatal error: require_once() [function.require]: Failed opening required ‘C:sitiossitiosocial/wp-content/member-themes/buddypress-home/index.php’ (include_path=’.;C:xamppphppear’) in C:sitiossitiosocialwp-includestheme.php on line 822

    How you can see, the application doesn´t found a buddypress-home directory inside member-themes. So, we solve this making a copy of the buddypress-member and renaming it to buddypress-home.

    Changing the topic (I know this is out of forum). I´d like to make my own buddypress-home theme, and buddypress-member theme. Do you have any documentation about it???

    Alain

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Alain, try activating the ‘WordPress MU homepage’ theme. See if it happens.

    Avatar of Alainhc
    alainhc
    Member

    @alainhc

    When I activate the WordPress MU homepage theme it still happens.

    Avatar of Halfpint
    halfpint
    Participant

    @halfpint

    I am geting the exact same error. I will be trying all that has been suggested on here

    Avatar of Halfpint
    halfpint
    Participant

    @halfpint

    Ok I got mine working by moving the member-themes folder from wp-content/themes to wp/content as tekkie said above

    Avatar of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    This is a server or config issue. Not a bp issue.

    Avatar of Sounepatoune
    sounepatoune
    Member

    @sounepatoune

    Warning: require_once(/home/public_html/wp-content/member-themes/buddypress-member/index.php) [function.require-once]: failed to open stream: No such file or directory in /home/morisus/public_html/wp-includes/theme.php on line 822

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/public_html/wp-content/member-themes/buddypress-member/index.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/public_html/wp-includes/theme.php on line 822

    How do we address the path issue?

Viewing 21 replies - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.