Skip to:
Content
Pages
Categories
Search
Top
Bottom

Toolbar buddypress menu on iPhone and iPad

  • Avatar of rabbitholeio
    rabbitholeio
    Participant

    @rabbitholeio

    Hello.
    I got problem during test buddypress with my iPhone and iPad.
    All ‘buddypress menu has submenu’ in toolbar don’t work on iPhone and iPad. ‘User account menus( Edit My Profile, Log Out) work. but buddypress menus (Activity, Sites, Profiles, Forums…) don’t work. I expected to see 3rd level menu, but when I touch those links nothing happens. I tested with my site using wordpress 3.5.1 and buddypress 1.7. To be sure, I tested with this site (buddypress.org), and I got same result. When I Press those menu for a while and choose ‘open in a new tap’, It works. but if i choose just ‘open’, it doesn’t work. I searched this issue here and google, but I couldn’t find any article….

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of studiopeter
    studiopeter
    Participant

    @studiopeter

    I’m having the same issue.
    Is there a solution yet ??

    Regards,
    Peter

    Avatar of GearMX
    GearMX
    Participant

    @gearmx

    I was having the exact same problem (BuddyPress 1.8.1 & WordPress 3.6). I found a solution: I turned off “Show the Toolbar for logged out users” under the Buddypress settings. It seems that the image mapping for menus may get misaligned when that setting is activated (or possibly some other conflict)

    All of my menus work again on the iPad & iPhone :) It should work for you too.

    Avatar of GearMX
    GearMX
    Participant

    @gearmx

    Update: When logged in, I am replicating the problem due to the toolbar appearing in the header. The solution above works when a user isn’t logged in. Furthermore, “responsive mode” doesn’t have these issues.

    Avatar of husdom
    husdom
    Participant

    @husdom

    Ditto…

    Experiencing the same issue…

    Mr Fox

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.