Skip to:
Content
Pages
Categories
Search
Top
Bottom

Upgrading to Wpmu 2.8.4a Hint!

  • Avatar of Korhan Ekinci
    Korhan Ekinci
    Participant

    @korhanekinci

    I had problems auto upgrade my wpmu 2.8.1 to 2.8.4a

    (Ok, I am a brave man upgrading automatically! Just Lazy!)

    I was getting this error:

    Warning: copy(/public_html/wp-content/upgrade/wordpress-mu-2.8.4a/wordpress/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: No such file or directory in /public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 131

    This is how I fixed it after reading this

    http://ocaoimh.ie/wordpress-mu-2-8-3/

    Before upgrading, edit wp-admin/includes/class-wp-upgrader.php and look for line 697.

    if ( !$wp_filesystem->copy($working_dir . ‘/wordpress/wp-admin/includes/update-core.php’, $wp_dir . ‘wp-admin/includes/update-core.php’, true) ) {

    * See the “/wordpress/wp-admin/includes” bit? Change that to “/wordpress-mu/wp-admin/includes”:

    if ( !$wp_filesystem->copy($working_dir . ‘/wordpress-mu/wp-admin/includes/update-core.php’, $wp_dir . ‘wp-admin/includes/update-core.php’, true) ) {

    * Save the file and auto upgrade. I upgraded this afternoon without any problems after making that change.

    You just have to go in and type “-mu” after “wordpress”. No need to copy and paste.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of Tiptap
    tiptap
    Participant

    @tiptap

    works a treat

    Avatar of cbriere
    cbriere
    Participant

    @cbriere

    Hi Korhan,

    In these thread the user states that some items failed to work:

    http://buddypress.org/forums/topic/buddypress-103-with-wpmu-284a#post-22006

    I just installed 2.8.4a and would like to install for the first time BP 1.0.3

    Don’t want to install BP until make sure it will work. If I install BP and fails to work, could it be a problem to Deactivate it?

    Thanks.

    Avatar of Korhan Ekinci
    Korhan Ekinci
    Participant

    @korhanekinci

    I don’t think deactivating BP will be a problem.

    If you are in no hurry, within a few weeks there will be buddypress 1.1 and probably a new wpmu version. I would wait for that.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.