Skip to:
Content
Pages
Categories
Search
Top
Bottom

Upgrading WPMU from 2.7.1 to 2.8.4a

  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    I just ran into an issue upgrading one of my WPMU test sites. It is a site I have not yet upgraded to the 2.8 series, so I thought I would quickly do the upgrade this afternoon. But after going about my regular upgrading process, I went to log in as Site Admin to complete the upgrade, and it would not let me. Instead it fired the installation script assuming I was installing WPMU for the first time–even though I had the proper, current version of my site’s wp-config.php file in its proper place.

    After checking to make sure I did not make any mistakes in the upgrade process, I thought that there could be some issues with the version of WPMU 2.8.4 that was available via the “Download” link on the WPMU site. So as not to take any chances, I decided I would grab the tagged version directly from WPMU’s Trac ( http://trac.mu.wordpress.org/browser/tags ). Besides, my install was not functioning anymore.

    Just in case there was some issue going from 2.7.1 to 2.8.4, I decided that I would first upgrade from 2.7.1 to 2.8.3. Then, I would grab the tagged version of 2.8.4a and complete the upgrade. It went without issue taking about 8 minutes to do the double-path upgrade.

    I’m not sure if I would not have had any issues if I had just grabbed the tagged version of 2.8.4a and upgraded my 2.7.1 directly to that, skipping the above intermediate step. So, if you have any 2.7.1-based WPMU sites to upgrade, you may want to follow my procedure as well.

    By the way, in case you’re wondering, I never use the auto-upgrade feature built into WPMU. I prefer to upgrade manually. It really is simple and quick–once you’ve done it a few times.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Thanks Jeff, good to know.

    I don’t use the auto-upgrade feature as well!

    So you recommend going from 2.7.1 to 2.8.3 and then to 2.8.4a?

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    That sounds fun. I’m going to have to do this soon myself. :(

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    @r-a-y

    So you recommend going from 2.7.1 to 2.8.3 and then to 2.8.4a?

    I do recommend this approach. Although if you–or someone else–goes directly from 2.7.1 to 2.8.4a, I’d like to know the results!

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Might be good to poll the good folks over at the WPMU forums!

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Looks like there is a WordPress URL hack going around:

    http://wordpress.org/support/topic/307660

    Otto over at the WP forums suggests to upgrade as soon as possible, but I haven’t seen any reports on the WPMU forums yet.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Yep, it’s always important to upgrade your production sites as soon as possible once an update comes out.

    The site I was referring to in this post is one of my development sites on my localhost server. So, I don’t have to worry about security breaches as I do not have the site access any outside links. Of course, it also means that sometimes I am lazy and take quite awhile before upgrading it!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.