Skip to:
Content
Pages
Categories
Search
Top
Bottom

W3 Total Cache and Buddypress Log out issues

  • Avatar of acha5066
    acha5066
    Participant

    @acha5066

    I’m using W3 Total Cache and it’s causing me to not be able to log out properly. I click log out and then it takes me to the log out page and says you are logged out. However, if you go to the website again, the bp-admin bar is still at the top saying I’m logged in.

    Does anyone have a fix for this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of mafiasoph
    mafiasoph
    Member

    @mafiasoph

    i think it has a problem with caching and with the cookies of your browser. Not so sure but why not try to log out then clear your cookies. If nothing will change maybe other members will help..^^

    Avatar of mafiasoph
    mafiasoph
    Member

    @mafiasoph

    i think it has a problem with caching and with the cookies of your browser. Not so sure but why not try to log out then clear your cookies. If nothing will change maybe other members will help..^^

    Avatar of notpoppy
    notpoppy
    Participant

    @notpoppy

    I’m having the same problem. When I enable W3 Total Cache if I click log out it still shows me as being logged in. It takes a couple of refreshes to change it. Likewise when I log in it still shows me as being logged out.

    Wordpress 3.2.1
    Buddypress 1.2.9
    W3 Total Cache 0.9.2.3

    Clearing cookies has no effect on the problem. If anyone can suggest a fix, please do.

    Avatar of notpoppy
    notpoppy
    Participant

    @notpoppy

    The problem goes away if I disable page caching in W3TC but I’m not sure this is a satisfactory solution as the performance benefit of caching the pages is lost. More a temporary workaround than a fix.

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Are you using the setting to not cache for logged in users?

    Avatar of notpoppy
    notpoppy
    Participant

    @notpoppy

    Yes, I have “Don’t cache pages for logged in users” selected.

    Avatar of notpoppy
    notpoppy
    Participant

    @notpoppy

    I’ve upgraded to W3 Total Cache 0.9.2.4, which has recently become available, and this seems to have fixed the problem.

    I’m just giving it a cautious thumbs-up for now because it was an intermittent problem before and maybe I’ve just been lucky. But so far, so good.

    Avatar of mwbarker
    Matt
    Participant

    @mwbarker

    I’m having the same issue with the current version of BuddyPress/WP/W3TC. Anybody found a fix for this?

    I’m having the same problem as @mwbarker

    It’s all the latest updates. I run my live site with w3TC, have disabled cacheing for logged in users, but still having this problem.

    My localhost test site has W3TC disabled, and it’s no problems. I guess I’ll have togo through all settings one by one until i find out what’s causing this.

    <– Edit.

    Ok, this is weird….
    I believe this has to do with “Page Cache” settings.

    I disabled Cache home page (now, I can loign/logout no probs)
    Selected “Don’t cache pages for logged in users”

    Now, as a test, I visited a few of my pages, log out, no probs. Stay logged out.

    Now, if I visit a page, say “About”, if I login on that page, I can logout, visit the homepage, I’m logged out, but if I visit that page again, it shows me as logged in. When I try to logout of “About”, it send me to the:

    http://mywebsite.com/wp-login.php?action=logout&redirect_to=http%3A%2F%2Fmywebsite.com&_wpnonce=bb1shsjskdd (nonce verify page)

    Very odd.

    Keep true to the dreams of thy youth

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.