Skip to:
Content
Pages
Categories
Search
Top
Bottom

Whats the difference in group discussion between versions?

  • Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    I was able to get user discussion to work on all previous versions of BP that I tried. For instance wpmu 2.7.1, BP1 & bbpress alpha 6.

    I had user integration & group discussion working perfectly. Then, when I upgrade to BP 1.0.2, groups break. User integration is still fine, but group discussion won’t work.

    The only plugins I have installed are BuddyPress & buddypress-enable in forums. I’ve deactivated/enabled all plugins & components. Saved and resaved all settings. Made sure all xml settings are turned on.

    Any ideas??

    Thanks!!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    You could try using v1.0 of BBPress (random guess)

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Lots of subtle cookie things mostly. I haven’t tried WPMU trunk yet, but integrating WPMU 2.7.1, BP 1.0.2, and bbPress 1.0 should be the same as your tutorial.

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Would I be a pain in the butt if I asked someone to post all of the extras that were placed in wp-config & bb-config. Also a list of plugins that are enabled would be dandy.

    I seriously don’t know what the deal is but I just can’t get anything above BP 1.0 to work. I’ve tried on WAMP and GoDaddy (stop laughing) and it’s just not working. I’ve tried every combination of cookie codes & defines that I could find & plugins & bbPress versions. I kid you not, I have at least 20 installs & 500 groups created. It’s sad really. LOL

    Also, you can email the codes to admin at theeasybutton dot com if that works better for you.

    Again, I appreciate any help that all ya’ll can and have offered. =D

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I’m in the process of nuking my test site today and resetting everything up. It will be a vanilla configured setup, so I’ll be able to help in more detail in a few hours.

    Integrating the platforms is something I’m really passionate about so if I can help in any way I’m more than glad to. :)

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    I’ll be watching for your reply. =D

    Can anyone fix this for running on localhost – I know these settings are wrong but it’s what the bbpress integration plugin kicks out. It’s all in a directory called monday (as I’m sure you can tell)

    define( 'COOKIEHASH', '519146fcc733b211cc72c7312b84bd28' );
    define( 'COOKIE_DOMAIN', '.127.0.0.1' );
    define( 'SITECOOKIEPATH', '/monday/' );
    define( 'ADMIN_COOKIE_PATH', '/monday' );
    define( 'COOKIEPATH', '/monday/' );

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    I’m running on localhost.localdomain and I don’t get that weird COOKIE_DOMAIN localhost IP when I go to the bbPress Integration settings in WPMU.

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    I’ll try a new install with localhost.localdomain. Anything I’ve ever tried in the wpmu setup other than 127.0.0.1 didn’t work. Thanks r-a-y

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Update — Used localhost.localdomain when installing wpmu. I’m now running BuddyPress 1.0 & bbPress 1.0 Integration is perfect & group discussion is enabled.

    As stated in my first post, whenever I go to BuddyPress 1.0.2, everything goes all stupid with group discussion. Automatic upgrade won’t work for me so am I just suppose to overwrite the buddypress folder with the new version? Thanks for all of your help!!

    Avatar of josemv
    josemv
    Participant

    @el_terko

    Reading Chris´update, I think I will continue sticking to Alpha 6 release…

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Hey Chris,

    Have you tried just installing BP 1.0.2, bbPress 1.0 and WPMU?

    Instead of starting from BP 1.0 and then upgrading?

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Yes r-a-y. I’ve done that. Tried bp1.0.1 also. I’ve seriously tried like every combo I can think of. I shall return with news of new installs. LOL

    Alright — I now have the most recent version of everything running via upgrading from bp1 & from bbpress alpha 6. So that means it does work on my computer & now I have all of the settings. Now to see if I can get it to all install fresh. *sigh*

    Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Yay! :)

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Yay – and back to Boo!!! Why the heck won’t this stuff install fresh?

    Recap — I upgraded from bbpress alpha 6 to bbpress 1 – all works

    Upgraded from BP1 to BP1.0.2 and all works

    But now, (fresh install) I install bbpress 1 & BP1.0.2 and discussion just refuse to work.

    I checked both config files vs the working install & everything matches up.

    Checked all xml settings and they’re on.

    Checked all forums settings pages & they match with the working install.

    The only plugins on the working install are BP and bbpress-integration. Same on non-working fresh install.

    Could there be a file missing from one of the installs that would remain during an upgrade but wouldn’t be there if I’m installing fresh? (I’m not this stupid dangit lol It shouldn’t be this hard)

    As always, thank you for your help.

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    I’m gonna go ahead and mark this as resolved because basically, I give up. I went back to my working install (where I successfully made 5 groups) and now discussions are disabled again. No changes were made, it just decided it didn’t want to work anymore. So for now, I shall accept defeat. 3 days solid is enough for me.

    Avatar of TheEasyButton
    TheEasyButton
    Participant

    @theeasybutton

    Yeah – I’m back… meh……

    Has anyone installed bbpress 1.0 from scratch and got group discussions to work? After another 20 or 30 installs, I’ve decided that there’s gotta be something in alpha 6 that buddypress is looking for. Something that bbpress 1 doesn’t have. I say this because I can get all of this stuff to work together but ONLY if I upgrade from alpha 6. I don’t dare try the RC versions.

    When doing the upgrade, the database is updated & gives the following info

    Beginning upgrade…
    >>> Modifying database: monday3 (localhost)
    >>>>>> Table: bb_term_taxonomy
    >>>>>>>>> Adding index: taxonomy
    >>>>>>>>>>>> Done
    Making plugin directory at C:\wamp\www\monday3\forums/my-plugins/: bb_upgrade_1110
    Making theme directory at C:\wamp\www\monday3\forums/my-templates/: bb_upgrade_1120

    Is it something in that update that does it or is there a specific file that’s left over from alpha 6 that has data that buddypress needs? It seems like if I delete the forum files & then upload the new version’s files, it still doesn’t work. But if I just rename the bb-config file & do an overwrite, the upgrade works fine.

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.