Skip to:
Content
Pages
Categories
Search
Top
Bottom

wp-activate.php instead of /activate

Viewing 4 replies - 1 through 4 (of 4 total)
  • I think we have a bug ticket for this, I’ll try to fetch it later.

    @andrea_r hi; do you still have the link to that trac ticket about the activation url?

    Avatar of skolbloggense
    skolbloggense
    Participant

    @skolbloggense

    Any suggestion where I can do a temporary fix? I know html/php, just need to know where to mod to get it working asap. thx!

    Avatar of skolbloggense
    skolbloggense
    Participant

    @skolbloggense

    Ok, so I found this; http://trac.buddypress.org/ticket/2350. Its the same problem but priority changed from major to normal . Why? Its a show-stopper!

    Quote apeatling:
    “Why should all registrations be handled on the root blog? That seems like a bad idea and is fundimentally messing with the way WPMU works. If a user has a blog and settings allow, they should be able to add users via their blog and activate them via their blog”

    My users (blogers) want to have their blog closed and only people with accounts allowed to see their blog should be able to see it (using plugin additional-privacy.php). So, they go into users and hit “add user”, selects a username and fill out their friends e-mail address. This is when the URL gets wrong…

    The fact that I have a correct value (“activate”) in BP_ACTIVATION_SLUG does not change this faulty address that is being sent in the e-mail.

    So, this must be a bug, right? And what can I do to go around it temporary before it gets a permanent fix?

    Avatar of skolbloggense
    skolbloggense
    Participant

    @skolbloggense

    Ok, I am helping myself here.. I have read about mod rewrite, I am hoping the following code in .htccess will do the trick, temporary anyway, I just wish that I knew if this is an official bug or if it is my installation that is not good…

    `RewriteRule ^wp-activate.php$ activate`

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.