Skip to:
Content
Pages
Categories
Search
Top
Bottom

wpmuguru – working with bp-mu ticket

  • Avatar of Anointed
    Anointed
    Participant

    @anointed

    Per the ticket:
    http://trac.buddypress.org/ticket/2561

    I have made the changes to the latest bp download from the ticket, did not use the trunk as it looked much older than the current release, so that could be the source of my problems. ( I don’t mind starting over with the trunk if needed, it’s a quick change)

    Anyhow, I have a base install setup and running, but it does not seem to be functioning correctly. Mostly I end up with 404 errors on trying to reach sub-site bp instances.

    example:
    http://bp1.mydreamhost.net/activity/

    I was opening this comment thread in the hopes that maybe you had the time to dig into this with me to see what all is going to be required to get this patch working. It should be a pretty fun project and is one that many have requested here. I don’t mind turning on registrations on the demo site once all is working so that everyone can see what bp-mu is going to function like when it works.

    so far:
    1. I installed 3.0.1 with subdomain support
    – created a few subdomain sites to see if it worked and it is set up right, it does
    2. I installed bp 1.2.5.2 with the changes from the ticket
    3. I installed the buddypress group blog plugin and created a group blog for the group
    – that part ‘sort of’ worked. For some reason the plugin tries to create subfolder installs instead of sub-domains which obviously is not going to work.
    –I then created a subdomain site and then applied that site to the buddypress group — that worked just fine, but I am going to have to track down the problem as to why it’s not creating the subdomain instead of the subfolder as that would be really annoying
    4. I then installed a separate subdomain site that is not related to a group
    5. I activated bp-default on the new subdomain site
    6. This is where the errors start showing up with the 404 while trying to access bp on the subdomain site
    http://bp1.mydreamhost.net/activity/

    I know you are always very busy, but if you can point me in the right directions, I really don’t mind doing the heavy lifting to get this working. Who knows, maybe a number of people will jump on this project and we can all get bp-mu functioning as expected.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Ron Rennick
    Ron Rennick
    Participant

    @wpmuguru

    Did you define BP_ENABLE_MULTIBLOG in your wp-config.php?

    If you want to run BP on all of the sites/blogs in your network, that’s done with the constant above. That isn’t what my patch was for. Secondly, my patch only provides hooks for a plugin to implement social network segregation. With just my patch applied BP should continue to work the way it did without the patch.

    Avatar of Anointed
    Anointed
    Participant

    @anointed

    Yes I have enable multiblog set to true in the config file.

    I’m guessing that I must have misunderstood the patch. I thought by installing bp with the patch included in all the files that it would allow each of my multisite blogs to have their own ‘instance’ of bp. After looking through the db though, I can see that a new ‘instance’ of bp tables are not spawned for each blog.

    Still continuing in the quest to run a single install of wp-multi where each of my blogs can have their own ‘instance’ of bp, basically bp-mu. Thought at first glance that this patch did that.

    Sorry for the confusion. Thank you so much for responding though, it’s greatly appreciated.

    –praying for the day that I can finally get back to one install of wp for all my clients. Many of them want bp, so unfortunately I am back to having to manage a bunch of separate wp installs. Just makes updating and maintaining everything very time-consuming.

    –curious if you are actually developing a plugin to implement the social network segregation or not. Spoke to JJJ a long time ago, but it has since dropped off his radar due to his workload.

    Avatar of Ron Rennick
    Ron Rennick
    Participant

    @wpmuguru

    I have both a dev and live BP site running with BP_ENABLE_MULTIBLOG and the BP social network works fine on all sites/blogs. So, if it’s not working for you on the sub sites (with or without the patch), then you have another issue somewhere (conflicting plugin, etc.).

    Assuming the patch is added to BP, I will be writing a simple plugin that will segregate BP by WP network.

    Avatar of Anointed
    Anointed
    Participant

    @anointed

    Yes, I must have a conflict somewhere, it’s a new install so will remove the patches and start over to get bp-multi working. No big deal there as I have it working on my live sites already.

    I really look forward to your plugin someday. When your ready let me know and I’ll help with the beta. Heck if it’s a small project, I would be willing to help pay for the development in some fashion. Anything to not have to keep maintaining so many separate wp installs would be a dream for me. I really wouldn’t mind even if I had to maintain my own vs. of bp until the patch is added. There are so few changes needed that updating would be no big deal.

    thanks again

    Avatar of A Weathers
    A Weathers
    Participant

    @aweathers

    so will this definitely be available in 1.3?

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.