Skip to:
Content
Pages
Categories
Search
Top
Bottom

Slider/ Jcarousel / jquery not working on latest BuddyPress?

  • Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    Hi all

    I have a few plugins that make use of a jquery based slider script but no matter what I do I can’t seem to get them working?

    I have tried commenting out the loading of jquery.js as I know BuddyPress loads this later on etc but no luck :(

    I am using BuddyPress 1.0.1 by the way with no other plugins enabled on my 2.7.1 MU install that is fully integrated with BBPress and everything else is working brilliantly so any ideas?

    Many thanks in advance

Viewing 18 replies - 1 through 18 (of 18 total)
  • Profile photo of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    Got a link to your site we can see? What plugins exactly?

    Profile photo of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I know that WordPress 2.8 uses the updated jQuery version, which will tend to break some older jQuery based scripts (it did on my portfolio site) but I’m not so sure about BP or WPMU.

    Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    Thanks for the replies guys.

    I have managed to isolate this down to the wp_head(); call in my header and THINK the jQuery version that WordPress loads, wp-includes/js/jquery/jquery.js?ver=1.2.6 is not compatible with the scripts I am using which used to load jquery-1.2.3.pack.js

    The script I am currently fighting with is the following jCarousel one here</> if anyone is interested although a slider one also doesn’t work but one thing at a time :)

    Profile photo of Burt Adsit
    Burt Adsit
    Participant

    @burtadsit

    js apps just don’t play nice with each other.

    I ran into this issue before and had to hack the plugin that was relying on an older version of jquery. It worked but it was only going to work on my site. I couldn’t expect anyone else to do the same thing. I just abandoned the use of the plugin that relied on a prev version of jquery.

    Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    Thanks Burt

    I understand what you are saying :)

    It is soooo infuriating though as I am not a jQuery coder so can’t pinpoint the exact issue but I will battle on.

    Looking forward to getting fully involved with the BuddyPress community once I have this current project sorted too!

    Profile photo of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Wait until the new version of WPMU comes out and uses the NEWER version of jQuery, you’ll get to go through this all over again. :)

    Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    Yeah JJJ – can’t wait!

    All this hassle has made me realise that if I want the benefits of WordPress MU then I need to switch the ‘sliding’ components that were working on the old, standalone wordpress blogs to something that keeps up (well nearly at least!) with WPMU and it’s jQuery updates :)

    Profile photo of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    It’s either that, or get used to keeping track of several versions of each component.

    There’s a reason web developers ask to get paid as much as they do. :D

    Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    Does antone have any recomendations for BuddyPress compatible javascipt slider / gallery effects?

    Profile photo of Windhamdavid
    Windhamdavid
    Participant

    @windhamdavid

    Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    I have actually gone for the wp-carousel plugin and removed the call to jquery.js that is comes with built in and it seems to be working well with the verison of jquery BuddyPress uses!

    Thanks for all the help.

    Profile photo of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    As thebloghouse has resolved the thread’s original issue, I’m setting this thread to resolved.

    @thebloghouse

    As the originator of this thread, you can always reset to “not resolved” if need be!

    Profile photo of thebloghouse
    thebloghouse
    Participant

    @thebloghouse

    Cheers Jeff – didn’t realise you needed to set the threads as resolved. Will do in future!

    Profile photo of Windhamdavid
    Windhamdavid
    Participant

    @windhamdavid

    Profile photo of Carlos Perez
    Carlos Perez
    Participant

    @carlosepp

    Profile photo of Nirok
    Nirok
    Participant

    @nirok

    Try using an older jquery: jquery-1.3.2.min.js rather than the latest

    Profile photo of pluggyboy
    pluggyboy
    Member

    @pluggyboy

    I had the same problem with jcarousel and buddypress, and paid a few dollars over at wpquestions to get the fix, which involved editing a line of code in a buddypress js file which handles easing. The full answer is here if anyone else gets stuck: http://wpquestions.com/question/show/id/1615

    hth

    @pluggyboy: Thank you, worked for me also.

Viewing 18 replies - 1 through 18 (of 18 total)
  • The topic ‘Slider/ Jcarousel / jquery not working on latest BuddyPress?’ is closed to new replies.
Skip to toolbar