Skip to:
Content
Pages
Categories
Search
Top
Bottom

1.6 beta – forums setup

  • Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Anyone else confused by the 1.6 beta – forums setup ?
    Using WP 3.4, BP 1.6 beta

    I’m trying to get sitewide forums working.
    In wp-admin: Settings-BuddyPress-Forums
    I see buttons to install: Group Forums and SiteWide Forums.

    I have installed SiteWide Forums and activated it.
    So why does Settings-BuddyPress-Forums still have an install button ?
    And do we really need a separate bbPress plugin for site-wide forums?

    I can create a new forum in wp-admin

    I created a page “…com/forums”
    I’ve assigned it to Discussion Forums in bp-settings – Pages
    If I go to that page, I get this
    “The forums component has not been set up yet.”
    And the Forums link does not show up in the main nav.

    In Settings- Forum -Archive Slugs – Forums base is set to ‘forums’ shows this warning:
    “Possible BuddyPress conflict: Forums page”
    If I set it to ‘forumsbb’ – the warning goes away.

    If I go to Forums in wp-admin and view the forum, it takes me to
    “…com/forumsbb/forum//test-forum/”

    But the Forums link is still not in the main nav.
    And goes to /forums still gives me
    “The forums component has not been set up yet.”

    How to correct those issues ?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    == So why does Settings-BuddyPress-Forums still have an install button ? ==

    @shanebp I agree. Will you do the honors to raise this in trac?

    == And do we really need a separate bbPress plugin for site-wide forums? ==

    Yes :-)

    == I’ve assigned it to Discussion Forums in bp-settings – Pages ==

    If you’re not going to use Group Forums, disable the component in BP 1.6beta1 in Settings > BuddyPress > Components – uncheck Discussion Forums and Save. You don’t need to assign Sitewide Forums Page in BuddyPress > Pages. Just add the Sitewide forums slug in the custom menu.

    In Settings > Forums, if you’re using “Forums” as slug, then create a page named “Forums” then add the forums shortcode/s you prefer http://codex.bbpress.org/shortcodes/

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    @mercime

    Thanks for the info.

    I think more Forums set-up info is a must and perhaps is better delivered in a bbPress codex page specifically for BP.
    And provide a link on the bb-forums-setup page
    Or it could go right on the bb-forums-setup page.

    A start to discussion:

    http://buddypress.trac.wordpress.org/ticket/4292

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.