Skip to:
Content
Pages
Categories
Search
Top
Bottom

Activity post time incorrect under Ajax

  • Avatar of parakeet
    parakeet
    Participant

    @parakeet

    When I post a status update, the time appears as “five hours earlier”. Except if I reload the page. Then it appears just fine.

    How can I resolve this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    And your timezone is EST ?
    And in wp-admin/settings you’ve chosen an East Coast city in the timezone option ?

    What version of WP and BP are you using ?

    Avatar of parakeet
    parakeet
    Participant

    @parakeet

    WP 3.5.1
    BP 1.7b2, the one out last night

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Do you feel comfortable adding a code snippet to bp-custom.php or your theme’s functions.php ?

    If so, try adding this:

    `update_option( ‘gmt_offset’, ‘-5′ );`

    And then see if the problem still exists.
    Either way, remove that snippet after testing.
    And let us know what happened.

    Avatar of parakeet
    parakeet
    Participant

    @parakeet

    I didn’t have a bp-custom.php. I made one in wp-content/plugins/ and populated it with…

    That didn’t work. Still showing “five hours ago” on both new status updates and replies.

    FYI, I am in the UK.

    Avatar of parakeet
    parakeet
    Participant

    @parakeet

    ++
    I checked WP time settings. I was UTC -5.
    I set it to London. No change.
    I set it to UTC + 0. No change.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    You’ll need to paste this snip in bp-custom, load the site, and then remove the snip.

    `update_option( ‘gmt_offset’, ’0′ );`

    Avatar of parakeet
    parakeet
    Participant

    @parakeet

    Still showing “5 hours ago”.
    Was that just to undo the earlier snippet or something?

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Yes, it was an undo.
    My guess was that it was related to an issue where timezone is set via wp-admin, but gmt_offset remains empty.

    I haven’t looked at the ajax re your report, but that would be the next step.

    Avatar of parakeet
    parakeet
    Participant

    @parakeet

    Ok, let me know if I need to file a bug report somewhere or something.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    I believe your report is covered by:
    https://buddypress.trac.wordpress.org/ticket/4573

    It’s a gremlin that doesn’t appear for most installs.
    It’s been reported in various guises for quite awhile.
    I was hoping that forcing a value into gmt_offset would solve it for you. :{

Viewing 10 replies - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.