Skip to:
Content
Pages
Categories
Search
Top
Bottom

Am I Just an Idiot? BP Installation

  • Avatar of startmywebpage
    startmywebpage
    Member

    @startmywebpage

    I’m fairly new to WP as a platform but I’m pretty sure I can install a plugin like BuddyPress, right now I have the default WP theme installed and wanted to setup BP. The problem is as soon as I go to activate after installation I get this:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 30720 bytes) in /mounted-storage/home59c/sub007/sc37816-TACW/www/wp-admin/includes/theme.php on line 159

    Not sure how I can have any issues as I have no Plugins activated and its a new install of WP, Should I have BuddyPress Template Pack installed first, before activation? I didn’t think this would matter at all, Either way I believe I tried it both ways yet I’m still getting a line error. What am I missing here? Seemed extremely easy to me, I also tried to manually upload to my file manager and I still get an error.

    Thanks In Advance, :(

    James

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Increase the amount of memory. If your install is on a shared hosting service, you may need to ask your host to increase the limit.

    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define(‘WP_MEMORY_LIMIT’, ’64MB’);)

    Avatar of startmywebpage
    startmywebpage
    Member

    @startmywebpage

    Thanks a lot Mercime :) Have it all figured out, made myself .htaccess and I’m good to go. Now to my next problem which im sure is easy to fix! Finally activated it and the default theme came up, only thing is I’m getting no links to my already made pages and i’m not sure why at all.

    http://www.drafro.com/

    Basically i can click on NOTHING…

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    === Finally activated it and the default theme came up. ===

    By default theme, you mean twentyten default theme. You need to go to Appearance > Themes and activate bp-default theme. Better yet, create a child theme of bp-default and activate that.

    === I’m getting no links to my already made pages and i’m not sure why at all. ===

    Make sure that mod_rewrite is enabled in your server as “pretty permalinks” are required for BP components to work in your install. If you’re using bp-default or the child theme of bp-default the Pages you created should be rendered in header area after the BP component links.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.