Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatar crop preview wrong

  • It is really hard to explain but…
    I’m using BuddyPress Template Pack to adapt Oxygen theme by devpress to be compatible with buddypress. Everything works very well except for the avatar cropping thing.
    When you upload a pic, and then use the cropping tool, the preview inside the crop and the preview below shows the wrong size, coordinates, and ratio. Ive been looking for a way to fix it but just cant. I disabled all js from my theme and still the same.

    So…is there a way to know whats going on?
    if not, is there a way to just leave the crop without preview?

    you can check my issue in http://www.graficacolectiva.com/wp-admin
    user: usuario
    pass: usuario

    oh and this happens with my theme, with default, the cropping works well.
    there are a lot of changes to be done in the css so not all pages look good (still working in the template pack)

    Thanks, hope someone can help me!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    Your theme is possibly trying to make fluid images that resize in a responsive manner if those rules happen to target the crop screen then it will muck it up.

    there was something in the css that managed all images, it worked adding this code:

    `#avatar-upload-form img, #create-group-form img, #group-settings-form img, #avatar-upload-form img, #create-group-form img, #group-settings-form img{max-width:inherit; }`

    Avatar of Henry
    Henry
    Member

    @thirstcard

    @ikosweb this CSS is essential for the avatar cropping feature. If anyone is developing their own theme and has decided to disable the default BuddyPress CSS then try adding this CSS snippet to your theme’s .css

    Avatar of applegateian
    applegateian
    Participant

    @applegateian

    I tried adding this CSS and it hasn’t fixed it for me. The crop function doesn’t show at all.

    Anyone have any ideas?

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.