Skip to:
Content
Pages
Categories
Search
Top
Bottom

Avatar Uploads with incorrect permission level…

  • Avatar of webeditor
    webeditor
    Member

    @webeditor

    Howdy everyone! I’m experiencing a very strange problem, hopefully someone out there has experienced the same and can point me in the right direction. Whenever one of our site users tries to upload an avatar, the upload goes through (I can see the file on the backend through FTP) but the uploaded file’s permission is set to 600 rather than 644, so no one (even the uploader) can see the image, crop it, etc…. We’ve never had this problem before, so I’m thinking it is because of a recent move to a new server–but I was needing to know if there is a way to change what file permission an uploaded avatar is automatically set to. Or is this a server-side configuration that needs to be changed? Thanks in advance for any advice you can give! BTW, we’re running WordPress 3.2.1 and Buddypress 1.2.9 on a virtual private server with Lunarpages.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    What happens permission-wise if you upload a file from the wp media library?

    Avatar of webeditor
    webeditor
    Member

    @webeditor

    Interestingly enough, WordPress-side media uploads work just fine. Correct permission is assigned with those uploads, and also with BP Album+ (both come through at 644). It seems to be isolated to the avatar uploads in Buddypress only. The avatar uploads, but comes through at permission level 600. The file owner and group are the same as all of the other files uploaded as well, so it’s not a file ownership issue that I can see…

    Avatar of webeditor
    webeditor
    Member

    @webeditor

    Hey Paul–I just now noticed also that the image that gets uploaded is always incorrectly cropped as well. It seems to be automatically cropping to the bottom right section of all photos (large and small)… Very strange as it was not doing this for months before! Is anyone out there experiencing these same troubles with the avatar uploads? I’ve been experimenting with all the other ways to upload images (through the media uploader, from within posts, as well as using the BP Album+ plugin) and all of them work perfectly. It’s seemingly isolated to the buddypress avatar uploads. Thanks in advance for any advice anyone could give me!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Have you checked whether it is a plugin or theme conflict by deactivating all plugins except BuddyPress and changing to bp-default theme?

    Avatar of webeditor
    webeditor
    Member

    @webeditor

    Hi Mercime–I just gave your suggestion a go and with only WordPress and Buddypress running with the bundled Buddypress default theme, the avatar upload error still occurred… Do you happen to know if there is any server-side configuration that needs to be in place for the avatar uploads in specific? I’ve also asked our web hosting company to look into the error as well to see if they could see anything on the server side… It’s quite peculiar, because all the other media upload areas work just fine…

    Avatar of webeditor
    webeditor
    Member

    @webeditor

    I wanted to take a quick moment and let everyone know our issue has been resolved. What seems to have gone awry was a suPHP configuration that was correctly allowing WordPress side uploads go through with permission 644, but not Buddypress. We run a VPS, so I had the provider’s technicians reconfigure the suPHP settings to allow both WordPress and Buddypress uploads to automatically be set to permission level 644. As of now, things seem to be running smoothly.

    So if you’re running a VPS or anything else where you can control the suPHP and PHP settings, be sure to give them a look and ensure they’re behaving as if they were running a shared hosting setup. By default, they are not as open as WordPress and Buddypress need to operate correctly.

Viewing 6 replies - 1 through 6 (of 6 total)

The topic ‘Avatar Uploads with incorrect permission level…’ is closed to new replies.