Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Blank Page Forum for Users

  • Avatar of John Conner
    John Conner
    Participant

    @johnconner

    wp 3.5.1
    bp 1.7
    group forum works well for Administrators. other wp or bp roles can create topics and send in groups, but they just have access to admin topics, their topics are shown as a blank page for them! any idea?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of John Conner
    John Conner
    Participant

    @johnconner

    @mercime
    would you please help me
    detailed description:
    admins can make topic and post in group forums,
    other roles can make topic and post in group forums,
    admins can see every topics and posts of group forums,
    other roles face a blank page when they open a topic of group forum.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @johnconner Need more information about your installation.
    – WP single or multisite? If multisite, is BP in main site or subsite?
    – Is this a new installation of did you upgrade from BP 1.6.5? If new, did you follow instructions at http://codex.buddypress.org/user/setting-up-a-new-installation/installing-group-and-sitewide-forums/ ?
    – Did you go through basic troubleshooting like changing to BP Default theme and deactivating all other plugins except BuddyPress and bbPress and checking if issue is resolved?

    Avatar of John Conner
    John Conner
    Participant

    @johnconner

    @mercime
    – WP single 3.5.1
    – BP default theme
    – updated from 1.6.4 to 1.7 and had this problem before, I thought it would be solved
    – all plugins were deactivated except BP
    – the only challenge is users can’t see users’ topics

    Avatar of John Conner
    John Conner
    Participant

    @johnconner

    @mercime
    – WP single 3.5.1
    – not new install
    – BP default theme
    – updated from 1.6.4 to 1.7 and had this problem before, I thought it would be solved
    – all plugins were deactivated except BP
    – the only challenge is users can’t see users’ topics, even the creator of topic can’t see his/her post in group forum

    Avatar of John Conner
    John Conner
    Participant

    @johnconner

    Well, there was a very stupid reason for the problem and special thanks to “wpbadman_plus”. A code in .htaccess which stops bad search and queries was the why of happening:
    `RewriteCond %{QUERY_STRING} (//|%2F%2F|/%2F|%2F/|<||>|%3E|%00) [NC,OR]
    RewriteCond %{QUERY_STRING} (..|%2e%2e|%2e.|.%2e)(/|%2f) [NC,OR]`
    thank you everyone and god bless Boston.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @johnconner Glad you resolved the issue and thanks for posting back. Did you add that to your htaccess file to harden WordPress install?

    Avatar of John Conner
    John Conner
    Participant

    @johnconner

    @mercime No pal, I just installed OSE firewall and use its php modules instead.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.