Skip to:
Content
Pages
Categories
Search
Top
Bottom

Blog Posts Don’t Appear in Activity

  • Avatar of sims3fanatics
    sims3fanatics
    Member

    @sims3fanatics

    Hey there,

    I have always had this problem but it hasn’t really bothered me until this point. Click here for the website.

    I am running Buddypress on a sinlgle-blog wordpress installation (I also tried installing multisite but this didn’t help one bit) and on my activity stream, none of the blog posts ever appear. I heard that the privacy setting mess with this, but I have mine open. I have tried with multiple themes and without plugins. Is there something simple I have just missed blindly?

    Thanks in advance for any help.

    edit: not sure why I’m called Deleted User here?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of sims3fanatics
    sims3fanatics
    Member

    @sims3fanatics

    I guess nobody can help?

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    Have you activated blog and site wide activity and assigned a page to them in BP setting ?

    Avatar of sims3fanatics
    sims3fanatics
    Member

    @sims3fanatics

    Yes, there is a page for activity, but there is no option to “activate blog” and there is no blog page?

    My activity stream component (checked) does say this though:
    Activity Streams – Global, personal, and group activity streams with threaded commenting, direct posting, favoriting and @mentions, all with full RSS feed and email notification support.

    ^ I don’t see blog anywhere?

    Avatar of sims3fanatics
    sims3fanatics
    Member

    @sims3fanatics

    Any new help?

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    Sorry, i haven’t noticed that you’re on a BP single blog install.
    I’m not familiar with single install, but i guess you have to create a page called blog.
    In the bp settings, click on the tab “component” and check the “site tracking” box
    On the tab “pages”, assign this page to blog in the directory
    save

    But unsure if this works for single WP.

    Avatar of sims3fanatics
    sims3fanatics
    Member

    @sims3fanatics

    I enabled site tracking, but I was led to believe that was simply for buddypress (not my blog) to be informed of posts etc. – I actually thought it made no change, but I tested again and it worked! Only new posts will show, but it’s worked. Haha I feel like an idiot but thanks for helping!

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.