Skip to:
Content
Pages
Categories
Search
Top
Bottom

Budddypress not working on shared hosting

  • Avatar of walkmotion
    walkmotion
    Member

    @walkmotion

    Hi all,
    I have installed worpress 3.3.1 on my shared hosting server and tried to install buddypress 1.5.4
    But when i activated the buddypress plugin, the site is not working. The server given an internal erro 500. Please tell me a solution
    Thanks in advance

Viewing 9 replies - 1 through 9 (of 9 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Check what you have in your error logs. If you don’t where that is, do contact your webhosting tech support about the issue.

    Avatar of walkmotion
    walkmotion
    Member

    @walkmotion

    Hi, thanks for your answer
    I have tried it on two different servers. But the same error occurred

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Are you on Windows or Linux server or locally hosted on WAMP, MAMP, or XAMPP?

    If on webhosting service, did you install WordPress via webhost script like Fantastico or Simplescripts, etc.? Start from scratch and install WordPress manually as in upload via FTP/cPanel/etc. Otherwise, please check server requirements plus WP configurations http://codex.buddypress.org/getting-started/before-installing/#system-server

    Avatar of walkmotion
    walkmotion
    Member

    @walkmotion

    Hi, I am using a Linux server ( Not local server ) , and installed wordpress and buddypress manually using an ftp client. My server configurations are

    PHP Version : 5.2.9
    Mysql : 5.0.92
    Apache rewrite module not enebled
    I have not installed wordpress to the root directory of my domain.
    That is the directory where i installed wordpress is “www.mysite.com/demo”
    Thanks a lot for your answers

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    > Apache rewrite module not enebled

    You’ll need it enabled.

    and if issue persists and you have plenty of PHP script memory you will need to look at your server logs as mentioned earlier to pinpoint the issue.

    Avatar of walkmotion
    walkmotion
    Member

    @walkmotion

    Thanks Hugo. Let me try this way

    Avatar of Gabriel Gortan
    Gabriel Gortan
    Member

    @ggortan

    How can i get Apache rewrite module enable? or check if it is already enabled, because i am getting the same problem, i can activate the plugin but when i get to the end of the instsllation wizard of buddy press , crashes my wordpress and i canot access it anymore , but when i delete the buddypress of /plugins ot get back to normal … Im sorry but i am portuguese

    Avatar of @shawn38
    Anonymous

    Have you tried editing the .htaccess file? Make a copy of the current .htaccess then add the below code between the lines and save it to the .htaccess :


    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Options -Indexes

    # END WordPress


    Hope this helps!
    :-)

    Avatar of @shawn38
    Anonymous

    P.S. this code should also prevent directory browsing because I added:
    Options-Indexes
    If you don’t know what that means google it.
    Cheers!

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.