Skip to:
Content
Pages
Categories
Search
Top
Bottom

BuddyPress activity stream comments bug with this theme

  • Avatar of whitewolf1988
    whitewolf1988
    Participant

    @whitewolf1988

    WP 3.5.2 BP 1.8 bbPress 2.3.2 Flix Theme current version
    When you try to comment on a post in the activity stream post I get this error using firebug:

    http://s20.postimg.org/e45kp2v9p/cropped.png

    Then the page goes completely white with the exception of the number 0 in the top left of the screen. It is a fresh install and no other plugins are being used. If I activate the twenty twelve theme this error goes away so I narrowed it down to a theme issue. How can I fix this? Thanks!

    JFYI I have also tested it with WP 3.5.2 BP 1.7.3 and bbPress 2.3.2 so it is definitely a theme issue that needs to be addressed! I did this on a second fresh install so it is undeniably a theme issue.

    Also when commenting on an activity stream post I have noticed that in the browser URL address it spits out this weird URL when it redirects and goes blank but with the 0 in the top left of the page “http://localhost/my-site/wp-admin/admin-ajax.php#ac-form-3″ without the quotes.
    I have also raised a support request on the themes support forum but I have not received a response. Please help if you can. Thank you!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Avatar of whitewolf1988
    whitewolf1988
    Participant

    @whitewolf1988

    Bump please, Thank you!

    Avatar of meg@info
    meg@info
    Participant

    @megainfo

    Hi,

    Check the version of jquery used by the theme. try to replace it by the last version.

    Avatar of whitewolf1988
    whitewolf1988
    Participant

    @whitewolf1988

    @megainfo
    Hi and thanks for your reply. My themes js folder contains six js files. Is this what you mean? In that folder I have buddypress.js, jquery.greyscale.js, jquery.nivo.slider.pack.js, jquery.timeout.min.js, jquery.uniform.min.js, and onefile.js so am I supposed to replace one of these or am I totally off track? I am really not sure what to do but any help is greatly appreciated. Thank you!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @whitewolf1988 per your theme’s page at marketplace, flix is compatible with BuddyPress 1.7.x, BuddyPress 1.6.1, BuddyPress 1.6. It probably needs to be upgraded for BP 1.8

    Avatar of whitewolf1988
    whitewolf1988
    Participant

    @whitewolf1988

    @mercime Hi and thanks for your help. I have BP 1.7.3 running but the same issue still. Should I try BP 1.7? Was there that many changes between BP 1.7 and BP 1.7.3 that would cause this issue? Obviously I would prefer using BP 1.8 but if this theme isn’t updated for it then I am prepared to downgrade the BP version to make it compatible. This theme is very complex and I really do not want to mess with its inner workings. I was disappointed to find out you can not even make a child theme for it because of its complexity. Thank you again and I will wait for your advice.

    Avatar of bp-help
    bp-help
    Participant

    @bphelp

    @whitewolf1988
    Looks like your using a test server anyhow so go ahead and try BP 1.7 and if it resolves the issue then you can upgrade to BP 1.8 when the theme author has updated this theme to work with BP 1.8. Sorry if this is not a complete solution but that is the risk you take when purchasing themes that are overly complex and are not promptly update for current versions of WP and BP! Good luck!

    Avatar of whitewolf1988
    whitewolf1988
    Participant

    @whitewolf1988

    @megainfo @mercime @bphelp I just tried it with BP 1.7 and the issue continues so what should I do now? Is there something I need to add from the buddypress folder to make it work right? I would supply a link but it is just localhost for testing. Thank you all for any help!

    Avatar of Jigesh
    Jigesh
    Participant

    @jigesh

    you need to fix it with no conflict jquery condition, if you don’t know it, than give me access to your site, i will do that. thanks.

    Avatar of whitewolf1988
    whitewolf1988
    Participant

    @whitewolf1988

    @jigesh Hi and thanks for your reply. The site is on my localhost not live so if you have links or other info that would help I will be gratefull. Thank you for your help!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @whitewolf1988 unfortunately, we do not have access to the premium theme nor your site to check if BP JS is enqueued or not, among other things. There are just too many variables to keep guessing what’s wrong with your theme’s compatibility with BP. The best place to to ask is at theme author’s site. If the theme author cannot help you at this time, think what would happen if theme development stops and you’re stuck with the theme and WordPress version it’s compatible with. Know that some premium themes lock you in so much so that if you try to change themes in the future, some content won’t show up anymore.

    Avatar of Jigesh
    Jigesh
    Participant

    @jigesh

    i agree with mercime, we can’t help you if you can’t have your site online.

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.