Skip to:
Content
Pages
Categories
Search
Top
Bottom

Buddypress pages redirect to homepage

  • Avatar of Az Mansell
    Az Mansell
    Participant

    @azmansell2010

    hi,
    i installed Buddypress onto my existing site yesterday and it was working fine. i started to modify the theme and managed to get everything working ok.

    I trialled about 3 different facebook connect plugins to see which worked the best (individually) but after that i noticed that if i, say, tried to mention a user or edit my profile the site would just redirect to the homepage.

    Is this something anyone has come across before.. i cant work out which was the offending plugin or what to do to fix it. my site is http://donnasdream.co.uk .. ive reverted back to the original theme but i will turn the buddypress plugin back on for people to have a look (please note, the theme its currently on isnt formatted properly but it should work)

    many thanks
    az

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I just checked out your site with Avenue K9 (BuddyPress BuddyPack) Theme. You seemed to have fixed redirect to homepage issues because I’m not being redirected to homepage at all.

    Avatar of Az Mansell
    Az Mansell
    Participant

    @azmansell2010

    Hi there, ive just noticed, it only seems to be happening to administrators?!

    if i sign up a new account that is just a subscriber it works perfectly fine.
    strange!

    Avatar of Az Mansell
    Az Mansell
    Participant

    @azmansell2010

    its actually quite annoying that i cant use the features as an administrator.

    does anyone know of a fix for this?

    Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    Did you try to create another Admin account and test to see if the same thing is happening?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @azmansell2010 what modemlooper said. Also, deactivate all BP plugins except BuddyPress and still if errant behavior persists.

    Avatar of Az Mansell
    Az Mansell
    Participant

    @azmansell2010

    ive found out its an issue with nice names having a space in between names, such as az mansell… logging into phpadmin and removing the space fixed the issue!

    thanks for all your help.. i have a new issue though but ill start a topic for it

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.