Skip to:
Content
Pages
Categories
Search
Top
Bottom

Can’t enable forums inside BuddyPress

  • Avatar of Hiranthi Molhoek-Herlaar
    Hiranthi
    Participant

    @illutic

    I’m working on an extranet for me and my clients and decided to use BuddyPress for it. I wanted to integrate bbPress and thought that for the button “Use an existing installation” I had to have bbPress itself enabled too. That didn’t work (I got the “you do not have enough permission” screen).

    Googling this I found that apparently BuddyPress has it’s own copy of bbPress in core, so I deactivated the seperate bbPress plugin and tried again: same screen.

    I then tried with the “Install Group Forums” button and also got the permissions screen.

    I’m running a Multisite installation (latest WP version, 3.4.2 from the top of my head), BuddyPress at the latest version and I’m logged in as the super admin (so I should have all the permissions there are). Oh and it’s a subsite of a second network in that installation and I did add the multisite define to wp-config.php.

    I tried with deactivating all other plugins: permissions screen. I already had the default BuddyPress theme active but tried with having TwentyTen enabled anyway: permissions screen and on top of that I can’t activate the BuddyPress Default theme anymore (“Cheatin’ huh?” and another – similar – screen when clicking on Live Preview).

    Does this ring any bells for anyone?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Hiranthi Molhoek-Herlaar
    Hiranthi
    Participant

    @illutic

    Oh and if this has been covered in the forums multiple times: search isn’t working for me (I get redirected to the homepage with just ?s added to the URL, adding it manually to the URL results in a search results page with titles only and a search form as the content of every result).

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @illutic haven’t encountered the permissions issue in WP 3.4.2 multisite with BP 1.6.1 installs – with BP installed in main site or where BP is installed in subsite (and defined in wp-config.php). What do you mean by “Oh and it’s a subsite of a second network in that installation and I did add the multisite define to wp-config.php.” Did you install the WP MultiNetwork plugin on top of the Multisite installation and added BP MultiNetwork plugin?

    Re Forums: to clarify between group and sitewide forums as well as activation steps http://codex.buddypress.org/getting-started/installing-group-and-sitewide-forums/

    Avatar of Hiranthi Molhoek-Herlaar
    Hiranthi
    Participant

    @illutic

    With the “Oh and it’s a subsite of a second network in that installation and I did add the multisite define to wp-config.php.” I mean the following:

    I have famire.nl as the main site (main network). I am using the ‘Networks for WordPress’ plugin by David Dean to be able to add multiple networks in my installation. My site onexa.nl is one of the networks.
    Inside that network I have a subsite called clients.onexa.nl (which I want to use as an extranet) and inside that site I have BuddyPress enabled.

    I understand differences between sitewide & group forums are btw (can’t remember mentioning the sitewide forums though). What I’m not sure of is what the “use excisting installation” & “install group forums” differences are.

    And just in case I need to have more added to wp-config.php, this is the BP related define I have in there: `define(‘BP_ENABLE_MULTIBLOG’, true);`

    Avatar of Hiranthi Molhoek-Herlaar
    Hiranthi
    Participant

    @illutic

    @mercime, I just created a new subsite and only activated BuddyPress and it’s giving me the same permissions error..

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @illutic

    Re permissions error:
    - Please post issue.when BuddyPress is installed in a network created by Networks for WP plugin at http://wordpress.org/support/plugin/networks-for-wordpress

    Re: what the “use excisting installation” & “install group forums” differences are.
    - If you have never installed Group Forums before, i.e., no bb-config.php at the root of your WP install, then you would click on “Install Group Forums” button
    - Click “Use existing installation” means using the Group Forums (BP’s internal custom bbPress) which was created in BP version prior to upgrade to latest version.

    Re: And just in case I need to have more added to wp-config.php, this is the BP related define I have in there: define(‘BP_ENABLE_MULTIBLOG’, true);
    - http://codex.buddypress.org/developer-docs/bp_enable_multiblog/
    At this stage, I suggest removing that from your wp-config.php until you resolve permissions issues

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.