Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Enabling members to see network sites/blogs

  • Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    I have WordPress 3.5.1 Multisite with BuddyPress 1.6.4.

    http://www.gumpolen.com

    Is there a step to enabling members to see other members’ sites? I created some basic register members, but the sites of others don’t show up on the sites page — only their own site shows.

    Is there a way so everyone can see everyone else’s site — or are they supposed to subscribe to these sites/blogs?

    Thanks,

    Kevin

Viewing 15 replies - 1 through 15 (of 15 total)
  • Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    Do members perhaps need to first “Friend” someone before their site/blog is visible to that person in the Site Directory?

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    Are members supposed to be able to see each other’s sites/blogs?

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    As an admin, I can see all of the sites when looking at the Site Directory.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @km-schafer-1 All subsites should be visible in Blogs Directory page by all unless Admin has changed privacy settings in Settings > Privacy from public to the other in some blogs.

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    @mercime

    Thank you for your reply. My head is really pounding from all of this. I feel like I’m going to vomit.  Oh, man.

    Would this privacy settings be in the network side or the gumpolen side? I’m trying my best to follow you.

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    @mercime,

     

    I have to take care of some Valentine’s Day things for my wife. I will return shortly. Thanks. Sometimes I wait until the last minute, but only for the minor things.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @km-schafer-1 please do go ahead and take care of the Valentine’s Day things for your wife :-)

    In adminbar/toolbar choose link My Sites > Network Admin > Sites and click on “Dashboard” link under a site which is not showing up in Blogs Directory. Go to Settings > Reading > Search Engine Visibility – ” Discourage search engines from indexing this site” is not checked.

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    @mercime That did it. Thank you for taking the time to show me the nav paths. Whew! The sites are all present to all members. I had no idea that this little tick box controlled all that! Lol! I’ll let all individual members control their own sites, but first I have to know what causes what.

    Thanks again.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    You’re welcome. Marking this as resolved.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I’ve raised this issue off site and consider it frankly bizarre, that setting was and is for adding a entry to the robots.txt file and as the descriptive text explicitly suggests is for discouraging search engines from indexing so what on earth has that to do with the ability of ones site to display data across the site(s) to members/users -  this also affects other activity on site iirc such as forum post activity stream display.

    imho this behaviour is badly wrong and a trac ticket needs opening to discuss this.

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    @hnla Someday I hope to know just a fraction of what you know. Thanks for looking into this. I would never have guessed in a  hundred years that this little check box affected something on the front end. Thanks, Hugo. You’re great!

    Your student,

    Kevin

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Second that. @hnla is great :-)

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    erm it was Mercime that pointed out the issue  so is due the thanks  :)  I just ranted a little then spent a half hour writing a trac ticket :)

    Avatar of Kevin Schafer
    Kevin M. Schafer
    Participant

    @km-schafer-1

    Good work @mercime and @hnla :)

    Avatar of Nathan Graham
    nathanegraham
    Participant

    @nathanegraham

    @hnla I totally agree and I’m battling this now

Viewing 15 replies - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.