Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal error and cannot deactivate BuddyPress 1.0.3

  • Avatar of localwpmu
    localwpmu
    Member

    @localwpmu

    I used the WP.MU “Community Start Up” package service and the setup was done 4 days ago.

    Today, I upgraded automatically to WPMU 2.8.2 and then automatically to BuddyPress 1.0.3 (without deactivating BuddyPress 1.0.2 – only realized I need to do that after encountering fatal error and found this page http://codex.buddypress.org/getting-started/upgrading-from-10x)

    Buddypress 1.0.3 appears to be installed, however the plugin can not be deactivated. When I click Deactivate, it says “Plugin could not be activated because it triggered a fatal error.

    Please advise, thank you.

    1. Version of WPMU 2.8.2

    2,3. Installed WPMU in root

    4. upgraded from a previous version of WPMU 2.7.1

    5. WPMU was functioning properly before installing/upgrading BuddyPress.

    6. Version of BuddyPress (BP) 1.0.3

    7. Upgraded from a previous version of BP 1.0.2

    8. No other plugins other than BuddyPress installed and activated.

    9. Using the standard BuddyPress themes

    10. Did not modify the core files in any way

    11. No custom functions in bp-custom.php

    12. Running bbPress ver 0.9

    13. No errors in server’s log files.

    PS: Should I contact WP.MU using their contact form or I can just post here for support?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of Windhamdavid
    Windhamdavid
    Participant

    @windhamdavid

    delete the entire Buddypress directory, refresh you plugins panel… upload it again, get your BP 1.0.3 themes in place.. refresh plugins.. activate it. i too.. always forget to deactivate plugins for upgrades ;o

    Avatar of localwpmu
    localwpmu
    Member

    @localwpmu

    I tried as per your suggestion but it doesn’t work. BuddyPress ver 1.0.3 still cannot be deactivated.

    After deleting the entire BuddyPress directory and refreshing the plugins panel, the plugin didn’t shows up (display blank) but the word “Deactivate” is still shown and upon putting the cursor over it, it is “www.mydomain.com/wp-admin/wpmu-sitewide-plugins.php?action=deactivate&plugin=buddypress/bp-loader.php&_wpnonce=1a9adedb1e”

    I tried on another domain with an upgrade of wpmu 2.7.1 to 2.8.2 followed by a fresh install of BuddyPress 1.0.3 and the same fatal error happened when I tried to deactivate BuddyPress in plugins panel. I did the same suggested recovery/resolution but the error persists.

    Any other approaches I can try? Thanks.

    Avatar of Windhamdavid
    Windhamdavid
    Participant

    @windhamdavid

    Make sure you have the themes in the proper locationI haven’t been following these forums too closely recently and I haven’t seen this error, but I went straight up 2.7.1 to 2.8.1 then 2.8.2. try this.. make sure you’re not refreshing a ?action=”*&^^” page.. just the plugins.php, delete out of the mu-plugins folder. refresh.. you should see NO Buddypress. drop it in the regular plugins folder.. refresh and then ‘activate site wide’.

    Avatar of localwpmu
    localwpmu
    Member

    @localwpmu

    This topic mentioned the same issue of not being able to deactivate buddypress 1.0.3 plugin after upgrade. http://buddypress.org/forums/topic/fatal-error-after-upgrading-to-wordpress-mu-282-and-buddypress-103

    Avatar of Andy Peatling
    Andy Peatling
    Keymaster

    @apeatling

    There is a bug in WPMU 2.8.2 that will not allow site wide plugins to be deactivated:

    http://trac.mu.wordpress.org/ticket/1071

Viewing 5 replies - 1 through 5 (of 5 total)

The topic ‘Fatal error and cannot deactivate BuddyPress 1.0.3’ is closed to new replies.