Skip to:
Content
Pages
Categories
Search
Top
Bottom

Fatal error in upgrade to 1.1.2

  • Avatar of elemsee
    elemsee
    Participant

    @elemsee

    Getting fatal error in upgrading BP that I’ve not found in forum search (long post, the “help us help you” information is lengthy)

    I followed the instructions in this post:

    http://codex.buddypress.org/getting-started/upgrading-from-10x/

    2) Which state to deactivate all BP-related plugins (I only had one, already deactivated)

    3) I deactivated Buddy press

    4) I downloaded latest version, uploaded it via FTP using Firezilla and overwrote the previous BP folder

    5) Returned to plugins page to re-activate BP, which is when I received this Fatal Error:

    Fatal error: Cannot redeclare bp_activity_install() (previously declared in /chroot/home/barliman/barlimans.com/html/wp-content/plugins/buddypress/bp-activity.php:19) in /chroot/home/barliman/barlimans.com/html/wp-content/plugins/buddypress/bp-activity.php on line 52

    Steps 6 I haven’t attempted

    Step 7: I was using default themes, but the instructions imply deleting bp-themes folder and etc. should happen *after* you reactivate BP.

    I’ve looked through the forum and didn’t find another “fatal error” instance with this particular problem, so, as per: http://buddypress.org/forums/topic/trouble-upgrading, I’m creating a new thread

    Here are the details pertaining to the “Help us Help you” questionnaire.

    1. Which version of WPMU are you running?

    Upgraded to 2.8.5.2 just prior to this

    2. Did you install WPMU as a directory or subdomain install?

    Directory

    3. If a directory install, is it in root or in a subdirectory?

    Directory

    4. Did you upgraded from a previous version of WPMU? If so, from which version?

    Yes, the immediate preceding version

    5. Was WPMU functioning properly before installing/upgrading BuddyPress?

    Yes

    6. Which version of BuddyPress (BP) are you running?

    it was 1.1.1, whatever the previous recent version was

    7. Did you upgraded from a previous version of BP? If so, from which version?

    See above

    8. Do you have any plugins other than BuddyPress installed and activated?

    When first attempting upgrade I did have non-BP plugins activated, but after first received error message, I restored my site, deactivated ALL plugins, but still received fatal error

    9. Are you using the standard BuddyPress themes or customized themes?

    Standard (only had replaced logo with our own, by adopting the default logo name)

    10. Have you modified the core files in any way?

    No.

    11. Do you have any custom functions in bp-custom.php?

    No.

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in?

    Not running BPress

    13. Please provide a list of any errors in your server’s log files.

    I can provide these if needed, but I think they’re preventing my post from showing up.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of elemsee
    elemsee
    Participant

    @elemsee

    Actually, geekjohn did post something similar two days ago, but no one has responded to him.

    I’ve tried a number of different approaches without luck, so if someone could please provide a tip, that would be great.

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    um…it shouldn’t cause anything if upgrading from 1.1.1 to 1.1.2.

    Make sure you don’t have any bp plugins on both plugins and mu-plugins directories. And try manually upgrading buddypress.

    Avatar of elemsee
    elemsee
    Participant

    @elemsee

    It shouldn’t, yes. But it did. :)

    The directions say deactivating bp-related plugins is sufficient, would you suggest deleting them from the plugin folders entirely?

    And I was manually upgrading.

    Avatar of elemsee
    elemsee
    Participant

    @elemsee

    Well this was the error message I was getting for whatever reason.

    `

    Downloading update from http://downloads.wordpress.org/plugin/buddypress.1.1.2.zip.

    Unpacking the update.

    Installing the latest version.

    Deactivating the plugin.

    Removing the old version of the plugin.

    Plugin upgraded successfully.

    Attempting reactivation of the pluginFatal error: Cannot redeclare bp_activity_install() (previously declared in /chroot/home/barliman/barlimans.com/html/wp-content/plugins/buddypress/bp-activity.php:19) in /chroot/home/barliman/barlimans.com/html/wp-content/plugins/buddypress/bp-activity.php on line 52

    Avatar of elemsee
    elemsee
    Participant

    @elemsee

    Well, ya know. It’s one of those things. I can’t tell you what I did, but poking at it repeatedly seems to have fixed it. It throws an error message back at me when activating, but now it’s working.

    Avatar of wpmubp.org
    wpmubp
    Participant

    @takuya

    buddypress sometimes show errors although it’s activated properly. But remember, there’s no activate/deactivate option for mu-plugins, so whatever bp plugin you have in mu-plugins has to be deleted (make sure you keep the copy at local) when upgrading.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.