Skip to:
Content
Pages
Categories
Search
Top
Bottom

Footer content appears in sidebar

  • Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    Yup. Strange but true: my footer content shows up at the bottom of the sidebar in IE, opera and Konqueror (according to Browsershots.org. Confirmed in IE7 on my machine. In Firefox, things are just fine though (no surprise there!)

    I’ve deactivated all plugins except BP and it appears to be a theme issue. I’ve tried several (adding a test div in the footer.php of each theme) and the problem persists with several themes including, hold on to your hat… bp-default.

    Thinking I may have inadvertently changed something in default.css, I downloaded a fresh copy of bp1.2.3 and replaced the file with a new one. Same problem.

    Hoping for some eagle eyes to take a look, I’ll leave the site as-is for now. http://rspace.org

    Anybody know of a fix for this?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Looks good in IE6/IE7 now pcwriter, probably you need to refresh browser?

    P.S. I saw my sidebar drop down when I was testing the updated BP Events plugin.

    Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    Hi Mercime!

    Nope… refreshed, reuploaded footer.php and still get it. Here’s a screenshot: http://i44.tinypic.com/20f2gy1.png

    PS – deleted bp-events and still get the weird sidebar.

    Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    Trying different themes again. Maybe I’ll find something…

    :-(

    Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    AHA!!

    Modemlooper’s widget theme works! Let me see if I can figure out why…

    Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    OK. I’m at a loss.

    Anybody know why the contents of footer.php would show up in the sidebar?

    Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    Well now, I’d really like to be able to show you how red in the face I am right now.

    After all this futzing around, I finally homed in on the source of the problem. Turns out, I made a newbie blunder and forgot to close a div tag in the last widget included in my sidebar.

    Umm… duh…

    Problem solved.

    Avatar of stwc
    stwc
    Participant

    @stwc

    That’s what I was about to say — it’s almost always an unclosed <div>. Hate when that happens!

    Avatar of pcwriter
    pcwriter
    Participant

    @pcwriter

    Ah well. My consolation is in that it simply proves I’m human after all…

    ;-)

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.