Skip to:
Content
Pages
Categories
Search
Top
Bottom

Getting 404 on every think that i click on Menu Bar – Newbie help

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of trusktr
    trusktr
    Participant

    @trusktr

    I’m having the same exact problem as well! Every page is Error 404. Fresh WordPress MU install followed by a fresh BuddyPress install. Error 404 on every page.

    Might this have to do with htaccess? Are files missing? (I re-installed, but problem still persists)

    Avatar of jamesb4551
    jamesb4551
    Participant

    @jamesb4551

    Same here, and I’ve tried moving the bptheme files to the wpmu theme files directory and activating them there and still the 404 error on everything, All the codex.buddypress pages have gone blank to for installation instructions too so yeah not looking great is it….

    Avatar of andrewliebchen
    andrewliebchen
    Participant

    @andrewliebchen

    I’m having the same problem. I will provide as MUCH information as I can per the list.

    Website here: http://test.risdarchitecture.net

    I’ve moved the BP themes to the wp-content/themes directory.

    This is the third clean install of WPMU and BP (including new SQL database, etc).

    I host with 1and1, so I’ve had to add a .htaccess file to the root directory to change to php5.

    1. Which version of WPMU are you running? WordPress MU 2.8.4

    2. Did you install WPMU as a directory or subdomain install? Directory

    3. If a directory install, is it in root or in a subdirectory? It is in the root, however the root URL itself is a subdirectory.

    4. Did you upgraded from a previous version of WPMU? If so, from which version? No.

    5. Was WPMU functioning properly before installing/upgrading BuddyPress? Yes.

    6. Which version of BuddyPress (BP) are you running? Version 1.1.2

    7. Did you upgraded from a previous version of BP? If so, from which version? No.

    8. Do you have any plugins other than BuddyPress installed and activated? No.

    9. Are you using the standard BuddyPress themes or customized themes? Yes.

    10. Have you modified the core files in any way? No.

    11. Do you have any custom functions in bp-custom.php? No.

    12. If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? BP came with an install of bbPress installed (I think).

    13. Please provide a list of any errors in your server’s log files. My site is hosted by 1and1. I don’t think they provide log files.

    Please help! I’ve read and read this forum and there doesn’t seem to be a definitive solution anywhere.

    Avatar of rustybroomhandle
    rustybroomhandle
    Participant

    @rustybroomhandle

    I am going to take a wild guess here that your Apache installation is missing the mod_rewrite module. It should be easy to install and likely in your distribution’s software repository.

    Just a guess.

    Avatar of danbpfr
    danbpfr
    Participant

    @chouf1

    @ andrewliebchen

    your problem is probably due to this: “. If a directory install, is it in root or in a subdirectory? It is in the root, however the root URL itself is a subdirectory.”

    shared host is not the best for wpmu+bp….

    verify that your hoster allows wildcard for your account or accept multiblog systems.

    Verify your wp-config.php file and show what is written in define vhost.

    Avatar of andrewliebchen
    andrewliebchen
    Participant

    @andrewliebchen

    Hey there, thanks for the help. I think that at the root of the problem is that 1and1 does not support multiblogs. Whoops. So, who knows if the subdomain as the root would also be problematic.

    Thanks for your help!

    1and1 seem to have issues with WordPress MU. If anyone else uses 1and1 and has problem, search this forum for previous topics.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.