Skip to:
Content
Pages
Categories
Search
Top
Bottom

Installing for Multisite – It’s asking for pages for various directories…….

  • Avatar of EliMadden
    EliMadden
    Participant

    @elimadden

    I’m installing Buddypress on a Multisite setup. It’s asking for the pages for various directories, but pages only exist on individual sites, they aren’t defined at the network level. So how am I supposed to set these at the network level when they don’t exist at the network level?

    When I tell it to create a new page from that screen it creates a new page only one one site. WTF?

    Am I overthinking this?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of @modemlooper
    @modemlooper
    Moderator

    @modemlooper

    BuddyPress only works on one blog, blog id 1. You need to create pages that will show directories for each BP component on that blog. You do not need to create these pages on every blog. BP will register content created on other blogs in your MU install and add posts to the activity stream.

    Also make sure you’ve activated the plugin network-wide.

    Avatar of EliMadden
    EliMadden
    Participant

    @elimadden

    Ok, I figured it out.

    First, I enabled Muliblog http://codex.buddypress.org/developer-docs/bp_enable_multiblog/

    Then I found that I needed to run Buddypress setup on each of the sites in the network, and I was able to have it create pages automatically for me.

    Note that the Buddypress installation isn’t really separate for each blog, it’s just shared.

    You can have 1 BuddyPress per WordPress network (a standard multisite gives you one network). You need to enable it sitewide, and set up the configuration from the root blog (the blog with ID = 1).

    You do not need to enable multiblog. I wish that setting didn’t exist.

    Avatar of EliMadden
    EliMadden
    Participant

    @elimadden

    How do I enable it sitewide?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Go to My Sites > Network Admin > Dashboard and to Plugins > Installed Plugins and click on the “Network Activate” link under BuddyPress.

    Avatar of EliMadden
    EliMadden
    Participant

    @elimadden

    I already did the network activate but it’s not showing up anywhere but the root site. I know it can work across them all……

    Avatar of EliMadden
    EliMadden
    Participant

    @elimadden

    Figured it out – BP_ENABLE_MULTIBLOG must be set to true to get the option to run the Buddypress Installation Wizard for each site.

Viewing 8 replies - 1 through 8 (of 8 total)

The topic ‘Installing for Multisite – It’s asking for pages for various directories…….’ is closed to new replies.