Skip to:
Content
Pages
Categories
Search
Top
Bottom

Issues after Upgrading Ajax Chat

  • Avatar of ericreynolds007
    ericreynolds007
    Participant

    @ericreynolds007

    I upgraded David’s ajax chat and now I’m having code show up above the chat box.

    The errors include AJAXChatHTTPHeader.php on line 37

    Warning: Cannot modify header information – headers already sent by ….

    Anyone else having issues? Any help appreciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Avatar of r-a-y
    r-a-y
    Moderator

    @r-a-y

    Contact Dave Aubin on his support group:

    http://getpaidfrom.us/groups/buddypress-ajax-chat-support

    Avatar of Dfa327
    Dfa327
    Participant

    @dfa327

    Hi,

    Thanks Ray. You always got my back:)

    Eric, please make sure you chmod’ed the bp-chat/config directory to 777. It’s the most common issue with the chat as I write out the config files based on your global wp settings.

    Thanks,

    Dave

    Avatar of John
    John
    Participant

    @atomiccafe

    Hi Dave,

    I installed 1.3.2 fine but when I try to chat I get an error inside the chat page

    Parse error: parse error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or ‘}’ in /home/content/a/t/o/atomiccafe/html/upoubams/wp-content/plugins/buddypress-ajax-chat/bp-chat/chat/lib/class/CustomAJAXChat.php on line 14

    Here are the Lines:
    10 #error_reporting(E_ALL);
    11 #ini_set(‘display_errors’, ‘1’);
    12
    13 class CustomAJAXChat extends AJAXChat {
    14 public $bp_config = array();
    15 public $channels = null;
    16 public $users = null;
    17
    18 public $loggedin_user_fullname = null;
    19 public $xml_logout_url = null;
    20 public $loggedin_user_id = null;
    21 public $name_type = null;

    I have the latest BuddyPress on a single instance of WordPress 2.9.2

    Can you help?

    Thanks

    Avatar of John
    John
    Participant

    @atomiccafe

    I fixed it.
    FYI, my hosting is PHP4 which causes the Parse error. I had to update it to PHP 5 and it worked.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.