Skip to:
Content
Pages
Categories
Search
Top
Bottom

Members cant register using BP Registration Form

  • Avatar of ri-kun
    ri-kun
    Participant

    @ri-kun

    I tried to register a new account tru the BP Registration Form. It went well, I even made a avatar. But when I tried to look for the account it cant be found. It even not listed in the lists of users.

    I have the latest version of WP and BP. I set the Registration Settings>Allow new registrations to “Both sites and user accounts can be registered” then theres is no ANYONE CAN REGISTER choice in Settings>General

Viewing 9 replies - 1 through 9 (of 9 total)
  • Did you activate the account via the email it sends you?

    Avatar of ri-kun
    ri-kun
    Participant

    @ri-kun

    There was no email sent to the email address I used in registering. and when I registered there were no notice that tells me that I have to activate my account.

    People who try to register on my buddypress install at http://our.windowfarms.org suffer from the exact same problem

    Avatar of ri-kun
    ri-kun
    Participant

    @ri-kun

    now, my problem become bigger. I tried to add a field on the registration form. Now, when I access the example.com/register it redirects to the homepage.

    Avatar of ri-kun
    ri-kun
    Participant

    @ri-kun

    oh, i’ve fixed the redirecting problem. whatas only left now is the same problem as neufuture. I wonder if the activation mail is part of the settings. I mean I have to turn it on first before it will function or something.

    Avatar of ri-kun
    ri-kun
    Participant

    @ri-kun

    I think i know now whats wrong. The activation email is not being sent to the person registering. or in the first place even if a notice confirming is being display after a successful registration it wasnt really register at all (since no email have been sent) but when I tried to use another email address which is already in use the system noticed it so I think theres something wrong with the activation mail or something.

    Avatar of Beck B
    Beck B
    Participant

    @beckb

    I had two users apparently never get the activation email. (One is me, so I know it didn’t go through, but the other attempt belongs to someone I don’t know. They MIGHT have simply never opened the email.) My first attempt used a hotmail (live.com) address. The other person’s is a personal domain.

    I thought I was having a problem with ALL activation emails, but when I tried a new user registration with a gmail address, it worked. I suppose I should test new user creation with some more email addresses and providers.

    In any case, if you don’t have tons & tons of new users, one thing you can do while “we” figure this out is to check the Users list under the WordPress settings (from wp-admin), as even unactivated users will show up there. Then visit any problem user in buddypress by manually typing in the address for their profile page (you know, something like http://www.example.com/members/USERNAME/). Then in the admin bar, you’ll find an option along the lines of “Admin Options->Mark user as not a spammer”. That’s probably not the exact text.

    Avatar of DS
    DS
    Participant

    @kebdarge

    With me registration doesn;t work. After filling in the form and clicking ‘continue’ people just get redirected to the same, now empty again, form.
    The page where they can choose the Avatar never showes up…

    Avatar of DS
    DS
    Participant

    @kebdarge

    Found the cullprit; the ‘SI Captcha’ plugin was preventing it because of a wrong set file permission.
    Check the plugin settings page and it will say what is wrong.

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.