Skip to:
Content
Pages
Categories
Search
Top
Bottom

Members Directory sort function not working

  • Avatar of tayenewm
    tayenewm
    Participant

    @tayenewm

    The sort members function in our members directory stopped working. Not sure how to fix this. Is there any known bugs? Also want to add a sort criteria which would be populated by one of the Profile question fields. Can you please advise on how to fix and add an additional sort item?

    I do not know code, so please give provide lots of details.

    thanks
    wp. 3.7.1
    BP 1.8.1
    Avada theme by themeforest 3.0.1
    http://www.youngwomeninenergy.com

Viewing 8 replies - 1 through 8 (of 8 total)
  • Avatar of tayenewm
    tayenewm
    Participant

    @tayenewm

    In addition to the sort function not working, it seems sending messages and inviting members to groups is broken as well. See attached screen shots – basically, when typing the member name, the system does not generate a selection of member names to choose from.

    I fear that my BP developer may have broken something during the last customization. Is there a way for me to easily figure out where the problem is or should I reinstall BuddyPress?

    thanks in advance,
    taye

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    |I fear that my BP developer may have broken something during the last customization.

    If you think that then ask them to investigate what’s happened, that is the normal course of events.

    | I do not know code, so please give provide lots of details.

    we can’t really ‘fix’ things for you without a significant amount of detail, and as BP has no issues this is likely the usual story of third party custom themes messing up or a errent plugin. You’ll need to test for those potential issues by reverting to a theme known to have no issues such as WP twentythirteen, and / or deactivating all plugins , re-activating one by one until the issue manifests itself again.

    Avatar of tayenewm
    tayenewm
    Participant

    @tayenewm

    I have tried to contact the BP developer multiple times – no response. I tested all plugins and the theme and the error did not resolve so I’m pretty sure the error in the BuddyPress.

    The host has advised the site is not throwing any errors. Not sure how to proceed. Wondering if I should just reinstall BuddyPress, import members and start again. Any concerns or advise?

    Avatar of Henry
    Henry
    Participant

    @henrywright-1

    @tayenewm there is a good chance this is down to your theme so reinstalling BuddyPress is most probably unnecessary.

    If the developer has modified any of the markup in members-loop.php then there is a good chance the modifications are what has broken the sort feature. The sort feature is dependent on certain page elements so if any class names or IDs have been changed or removed then that will be the source of your problem.

    As @hnla said, the way to resolve the issue is to revert to the default theme and work backwards, eliminating each customisation the developer has made as the source of the problem.

    Avatar of tayenewm
    tayenewm
    Participant

    @tayenewm

    I reverted to the default theme and deactivated plugins one by one and it did not fix the problem. I’m pretty sure the modifications broke the feature as well. And since the developer that last worked on it is MIA, I suspect he knows this.

    Can anyone just go in and check the members-loop-php code? At this point I would be happy to overwrite all customizations. I just need it fixed.

    I’m not technical that is why I thought reinstalling buddypress back to all default settings would be a solution – but I can’t remove members in the process.

    Please advise.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    > reinstalling buddypress back to all default settings

    That won’t fixed any issues introduced via /plugins/bp-custom.php
    Make a copy of that file and then delete it from your server.

    Also deactivate any plugins that ‘your’ developer installed.

    Avatar of Henry
    Henry
    Participant

    @henrywright-1

    @tayenewm just a thought – do you know if the developer made any customisations to the BuddyPress core? This is quite bad practice but it is a possibility. If that has happened then there are 3 options…

    1. live with a broken sort feature
    2. try to get in contact with the developer to see what changes have been made
    3. reinstall WP and BP

    Considering point 1 is unappealing and point 2 doesn’t look possible then I’d try point 3.

    Avatar of tayenewm
    tayenewm
    Participant

    @tayenewm

    Thanks for all the suggestions – really appreciate it. In the meantime, the developer also emailed me with a solution.

    Not sure how to proceed just yet. Will keep you posted.
    thanks again,

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.