Skip to:
Content
Pages
Categories
Search
Top
Bottom

No 404, Just Shows

  • Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Hi everyone.

    I am wondering how to make it show a 404 page for a page that doesn’t exist, instead of it just showing the standard layout with nothing on it.

    Thanks for any help!

Viewing 23 replies - 1 through 23 (of 23 total)
  • Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    We need more information to provide assistance. Please answer these questions.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Hey Jeff:

    Sorry I didn’t post that originally, didn’t exactly see the thread…

    1. Which version of WPMU you are running

    2.7.1

    2. Whether you’ve installed WPMU in a subdirectory or as a subdomian

    Subdirectory

    3. Whether you upgraded from a previous version of WPMU. If so, from which version.

    Nope, new install.

    4. Whether WPMU was functioning properly before installing/upgrading BuddyPress

    I suppose

    5. Which version of BuddyPress you are running

    Latest (1.0)

    6. Whether you have any plugins other than BuddyPress installed and activated

    Nope

    7. Whether you are using the standard BuddyPress themes or customized themes

    Standard

    8. If running bbPress, which version

    Not using it (tried it, too hard to install). ;)

    9. A list of any errors in your server’s log files

    N/A

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Pierce2-

    Thanks for the details.

    Carefully read this thread and see if that solves your problem. Post back in this thread either way.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Jeff:

    While I may be wrong, I believe that thread is more about the user getting 404 errors. My problem is that I’m not. ;) On any URL you type (/buddypress/asdaosdasd), it just shows up a blank page saying nothing.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    I believe that thread is more about the user getting 404 errors. My problem is that I’m not.

    Pierce2-

    You’re correct! My mistake.

    Okay, do have the the bpmember theme selected in WPMU’s backend?

    BuddyPress > General Settings > Select theme to use for BuddyPress generated pages

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Jeff:

    Yes, I believe that option is selected. It says “BuddyPress Default Member Theme”, whatever that is.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Okay, please verify that you have the following theme folders in the following places:

    bphome theme folder in /wp-content/themes/

    bpmember theme folder in /wp-content/bp-themes/

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Jeff:

    Yes, both of those folders are in the right place.

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Okay, to recap:

    • You are running a new install of WPMU 2.7.1 with BuddyPress 1.0
    • You’ve activated BuddyPress
    • You have no other plugins installed and activated
    • You are using the bphome and bpmember theme
    • You do not have any errors AT ALL in your server’s log files
    • You’ve installed WPMU as a subdirectory install
    • But, you are not positive if WPMU was working before you installed and activated BP

    Now, if I understand your issue correctly, when you visit your domain, you can see the home page without any issue. It works fine. But when you click on any link it brings up a blank page without a 404 message.

    Or, is it that everything works fine. You can see the home theme and get to the member theme without any problem. You are only seeing this issue when you provide a bogus url. It is only then that you get the blank screen? So, you are wondering why it is not a 404 page.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Or, is it that everything works fine. You can see the home theme and get to the member theme without any problem. You are only seeing this issue when you provide a bogus url. It is only then that you get the blank screen? So, you are wondering why it is not a 404 page.

    – That’s the problem… And the specifications of the install are correct.

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    Just noticed this too on one of my installs. Who is your web host? Are you by chance running BuddyPress in a subdirectory?

    Looks like you’re not using any plugins at all? Were you at any point? Something that additionally re-writes URL’s like qTranslate or the like?

    Correct me if I’m wrong, but you’re not getting a blank screen (white screen of death), you’re getting what looks like a totally empty blog page, with no widgets, no side bar, just a header and a footer.

    Right?

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Hey John:

    My host is HostGator, and yes, I am using it in a subdirectory versus the main directory or a sub domain. No, I have never installed anything that would have changed the URL structure of the app, unless BuddyPress would have done this… And yes, I’m not getting a white screen of death, instead I’m getting a totally empty page. Have you been able to fix this?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    John-

    From what I can gather from Pierce2, your assessment is correct. He’s done a subdirectory install, just gets blank screens with bogus urls, and is running plain vanilla BP–no other plugins, using default themes.

    Pierce2-

    What is your site’s URL?

    Avatar of John James Jacoby
    John James Jacoby
    Keymaster

    @johnjamesjacoby

    I think the problem here is that it’s installed in a sub directory. My guess is that if this is BP’s fauly, it’s hijacking the path and the 404 template page never gets triggered. Let me do some more digging tonight and see if I can patch this.

    Otherwise I’d say this might just be WPMU.

    As a general rule, WPMU doesn’t really like to be installed in a subdirectory off of the root of the domain.

    I.E

    domain.com/wpmu/member is bad

    domain.com/member is good

    Chances are this isn’t a BP issue at the core, but rather a WPMU issue. Worth looking into though.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Jeff:

    I’ll PM you the link, not quite ready to go public with it yet.

    John:

    That sounds like an accurate guess, but do you think I would just have an easier time doing an re-install somewhere else?

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Pierce2-

    Do you have any custom functions in bp-custom.php? Are you allowing access to certain sections only to logged in members?

    When I go to your site and enter some bogus urls, I do not receive a blank page. I get the bphome or bpmember page with the buddybar, search bar, footer, and a few other items.

    For instance if I type

    xxx.xxxxx.xxx/social/ssdsf/

    It does not error, but it is not blank. There is just very little content

    On a few bogus url attempts, it even redirected me the home page automatically.

    Since I am not logged in, I’m wondering if you are doing some sort of check.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Jeff:

    Nope, no custom functions – It’s a brand new install. And you may classify a page being “blank” different then I would. It doesn’t show a blank white page, what you are describing is correct. However, for a bogus URL, shouldn’t it show something like this?

    http://buddypress.org/asd/dasdasd/das

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    Pierce2-

    Yes, that is true. A bogus url should trigger the 404.php file in your theme directory.

    I think jjj is correct in thinking that this has something to do with the subdirectory install.

    From the link that you PMed me, it appears that for your production site, you will be doing a root-level, and not a subdirectory WPMU install. If that is the case, this issue will not be relevant and is just taking time away from your development. You should be prototyping using the same directory structure in your dev environment as in your production environment.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Hi Jeff:

    This is very true, and I thank you and everyone else for their help. I will probably switch it over to a root environment soon enough – Just have to find some time. ;) Before I mark this issue as closed, would anyone know why it keeps annoying me to put widgets to my blog? Or is this normal behavior? And the little alert box for it is going behind my text for the blog (I think this could have to do with the “menu bar full width” code, discussed in another thread).

    Avatar of Jeff Sayre
    Jeff Sayre
    Participant

    @jeffsayre

    why it keeps annoying me to put widgets to my blog?

    Yes, this is standard operating procedure based on the way the bphome theme is coded. If you decide to design your own custom home theme, look at the home.php file in the bphome theme folder. You’ll see how this is done.

    the little alert box for it is going behind my text for the blog (I think this could have to do with the “menu bar full width” code, discussed in another thread).

    That is probably the case. You’d have to look at the CSS. You could specify a z-index to correct the issue if it is too bothersome.

    Avatar of Pierce2
    Pierce2
    Participant

    @pierce2

    Standard operating procedure… Sounds interesting. I just added some widgets just to get it to stop annoying me, and I think it looks better this way.

    And as for the problems with the header extension, I don’t know if it’s worth it. It looks really nice but it just doesn’t behave in a “standard way”. For example, that menu bar thing as well as on the members page when the two sections (my options and their options) extend all the way the the head bar instead of staying where they should be (contained in their boxes).

    Avatar of Michael Berra
    Michael Berra
    Participant

    @miguael

    Sorry, to pick that thread up again… But the problem pierce2 was mentioning is exactly mine… I am running on a subdirectories install and that seems to be the problem (because in another subdomain-install) it just works fine…).

    So – has anyone a solution to this, because it’s not very good for google, if dead links point to a non existing blank-content-page…

    THANKS!

    Avatar of Michael Berra
    Michael Berra
    Participant

    @miguael

    Found something in the WPMU FOrums that fixed it temporarly for me: http://mu.wordpress.org/forums/topic/9458/page/2

Viewing 23 replies - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.