Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Pages are not showing up on my homepage

  • Avatar of DACentral
    DACentral
    Participant

    @dacentral

    I have the most recent wordpress and buddypress editions. (updated this morning. My issue started right when I installed buddy press and started to set it up though–which was earlier this week)

    My site link is http://dogagilitycentral.com/

    Okay so I am attempting to set up a niche social networking site for people who share my hobby. I installed buddy press and followed the instructions. I created pages to correspond with the buddy press component directories. The links that work are the activity streams, members, and user groups. I was also able to set up a log in area on the left of the page.

    My problems (probably somehow caused by me and I just am not savvy enough to realize it):

    -The ‘the search’ page, and the ‘register’ page are both under the buddy press template. They show up as being linked to the buddy press pages under “pages” in the buddy press setting section. However, when I click the “view” button, they redirect me to the homepage of my site.

    -Neither of the pages above show up on the left under links, even though I put the pages in the “community” parent. In the “pages” >> “All Pages,” the missing pages appear under the “community” parent and have proper permalinks listed. >_>

    -I tried to put the entire “community” collection of links in its own area underneath the page links on the left of the homepage, as you see. Did not work–still only those 3 that appear

    -I don’t have a forum page linked to the forum directory under buddy press pages but the direct link still works. however, when I did have a page assigned to it, it didn’t show up under links. I can’t figure out how to get the main forum page to appear under links. Right now I have one message board created and to get it to show up, I had to link it individually under the “forum” section on the left of the homepage. I want to have a link that just leads to the forum mainpage.

    Sorry if I made a mess of all this. x_x not sure what I did wrong. Any pointers would be greatly appreciated. Could this be a compatibility error with my theme? (which would make me very sad, but hey, whatever works I guess.) I installed the plugin that is supposed to walk you through setting buddy press up with your existing theme. However, when I activated it, it gave me a “fatal error” line, so I deleted it.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    However, when I click the “view” button, they redirect me to the homepage of my site.

    That happens when you go to the Register page while you’re still logged in. And, you have a page template name Search specifically for searching the site?

    Neither of the pages above show up on the left under links,

    Not getting why the pages should show up on the left

    I don’t have a forum page linked to the forum directory under buddy press pages

    Did you activate Group Forums or are you referring to Sitewide Forums (bbPress plugin required)?

    I installed the plugin that is supposed to walk you through setting buddy press up with your existing theme.

    I see that you are using Custom Community Theme.
    1. You don’t need to install BP Template Pack with that theme.
    2. Don’t know if that theme has been updated for BP 1.6.2 and WP 3.5
    3. For testing and general set up, use the BP Default theme first. When everything’s working and in their places, you can choose another theme.

    Avatar of DACentral
    DACentral
    Participant

    @dacentral

    Thanks for the help!! Okay, turns out all I needed to do was enable registration for the log in page to work (smh, self, smh >_>). Everything looks good now! Only issue left is that the forum link under the community section leads to the group forums that I enabled but looks like it is a single forum that can house new topics but not an actual variety of boards. Is there any way for me to make that a link to a parent forum that houses the different sub-boards that I would like? Again, thanks for the help so far. All of this is starting to make more sense to me. :)

    Avatar of DACentral
    DACentral
    Participant

    @dacentral

    Nevermind, I got everything solved! Downloaded something that lets me make a page redirect to a link to the forums.

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.