Skip to:
Content
Pages
Categories
Search
Top
Bottom

Profile pages not found error

  • Avatar of chewbaker
    chewbaker
    Participant

    @chewbaker

    I am wondering my profile pages are not showing up. When you click on a users profile, it takes you to the members directory and says page not found.
    I am running am running a clean install of wordpress 3.0 and buddypress (latest version) in a subdirectory (mysite.com/social/).
    I just can’t figure want is wrong? Anyone else having these issues?

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am also having this problem. Can anyone help me? Thanks in advance:

    I’m running wp 3.2.1, on main directory in root, using bp version 1.5.1that was never upgraded. I have no other plugins activated on the subdomain I’m running buddypress from. I’m using the standard bp theme that came with the plugin for this and I modified my wp-config to allow bp to run on subdomain (runs on members.mysite.com): here’s the info in bp-custom.php
    `<?php
    define ( ‘BP_ENABLE_MULTIBLOG’, true );
    define ( ‘BP_ENABLE_ROOT_PROFILES’, true );
    define( ‘BP_DEFAULT_COMPONENT’, ‘profile’ );
    define ( ‘BP_ROOT_BLOG’, $blog_id );
    define( ‘BP_SILENCE_THEME_NOTICE’, true );
    define( ‘BP_ENABLE_USERNAME_COMPATIBILITY_MODE’, true );
    define ( ‘BP_ACTIVITY_SLUG’, ‘streams’ );
    define ( ‘BP_BLOGS_SLUG’, ‘journals’ );
    define ( ‘BP_MEMBERS_SLUG’, ‘users’ );
    define ( ‘BP_FRIENDS_SLUG’, ‘peeps’ );
    define ( ‘BP_GROUPS_SLUG’, ‘gatherings’ );
    define ( ‘BP_FORUMS_SLUG’, ‘discussions’ );
    define ( ‘BP_MESSAGES_SLUG’, ‘notes’ );
    define ( ‘BP_WIRE_SLUG’, ‘pinboard’ );
    define ( ‘BP_XPROFILE_SLUG’, ‘info’ );
    define ( ‘BP_REGISTER_SLUG’, ‘signup’ );
    define ( ‘BP_ACTIVATION_SLUG’, ‘enable’ );
    define ( ‘BP_SEARCH_SLUG’, ‘find’ );
    define ( ‘BP_HOME_BLOG_SLUG’, ‘news’ );
    define ( ‘BP_AVATAR_THUMB_WIDTH’, 50 );
    define ( ‘BP_AVATAR_THUMB_HEIGHT’, 50 );
    define ( ‘BP_AVATAR_FULL_WIDTH’, 150 );
    define ( ‘BP_AVATAR_FULL_HEIGHT’, 150 );
    define ( ‘BP_AVATAR_ORIGINAL_MAX_WIDTH’, 640 );
    define ( ‘BP_AVATAR_ORIGINAL_MAX_FILESIZE’, $max_in_kb );
    define ( ‘BP_AVATAR_DEFAULT’, $img_url );
    define ( ‘BP_AVATAR_DEFAULT_THUMB’, $img_url );
    define ( ‘BP_FORUMS_PARENT_FORUM_ID’, $forum_id );
    define ( ‘CUSTOM_USER_TABLE’, $tablename );
    define ( ‘CUSTOM_USER_META_TABLE’, $tablename );

    ?>`

    Wiredtree is my server provider (I have a dedicated server with all access), and I’m running Linux w/ Apache

    Can anybody provide any answers for this. I noticed that instead of usernames being setup like this (members.mysite.com/members/user), the links connect me to members.mysite.com/user. Any help with this is appreciated. Thanks

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    The links connect of members.mysite.com/username because you added the code below to your wp-config.php. Delete it and the link will go to members.mysite.com/members/username
    `define ( ‘BP_ENABLE_ROOT_PROFILES’, true );`

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.