Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] 1.5.6 to 1.6 b1

  • Avatar of okso
    okso
    Participant

    @okso

    just moved up from 1.5.6 on site with existing working group forums and site wide forums using bbpress plug (2.0.3) and get following error only when I go to group forums, site wide still ok: Warning: mysql_connect() [function.mysql-connect]: Access denied for user ‘root’@’localhost’ (using password: NO) in ///wp-includes/wp-db.php on line 1038
    Error establishing a database connection

Viewing 6 replies - 1 through 6 (of 6 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I’m assuming since you didn’t mention it, that you have WP 3.4 running with BP 1.6 beta 1
    .
    Go to dashboard menu Settings > BuddyPress > Settings – Forums Settings – bbPress configuration, and make sure that you have the absolute path to your bbPress configuration file there ( for group forums located at root of your WP installation).

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Hm. Did you change your bb-config.php manually?

    Avatar of Ducksmobiel
    ducksmobiel
    Participant

    @ducksmobiel

    At 3 different places (and providers) problem with plufgin bp-groups-hierarchy:

    Fatal error: Cannot make static method BP_Groups_Group::group_exists() non static in class BP_Groups_Hierarchy in /home/werkgroe/public_html/collega/wp-content/plugins/bp-group-hierarchy/bp-group-hierarchy-classes.php on line 345

    Avatar of okso
    okso
    Participant

    @okso

    hi, thanks for response. Here’s my path, unedited from original instal under 1.5.6 and yes I’, on wp3.4 /var/www/vhosts/domain.com/httpdocs/bb-config.php
    I was looking at it last night thinking user root isn’t right, so went in and looked at bb-config.php and sure enough the config was from old MAMP local instal, its now on staging server. Once I’d put in the correct database credentials the ‘cannot connect error’ was fixed.

    *I’m now a bit perplexed as to how it worked before the 1.6 update. Its been up and running on server for a month with old MAMP creds on bp1.5.6

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    We broke Group Hierachy compatibility in Beta 1. We’ve fixed that now for the next release.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @okso Great. Glad you got that going.

    @djpaul that was fast, cheers.

    Marking this topic as resolved all around :-)

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.