Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] Replying to comments on posts – page not found. (IIS7 / Multisite – Buddypress)

  • Avatar of marc birkett
    marc birkett
    Member

    @marc-birkett

    Hi everyone,

    I am after a little guidance, I have managed to install Buddypress on a subsite in my multsite install. I have a web.config of rewrite rules which works for everything except leaving a reply to a post. This results in a page not found (404) error.

    I have altered the permalinks, have my redirect rules (below) and have set the appropriate root blog in wp-config.php. I’m stumped – any advice?

    Much appreciated.

    Marc

Viewing 7 replies - 1 through 7 (of 7 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @marc-birkett Could be a theme issue and not a BuddyPress issue at all.

    Your theme needs to have something like this
    ` if ( is_singular() && get_option( ‘thread_comments’ ) )
    wp_enqueue_script( ‘comment-reply’ );`
    in header.php or enqueued in theme’s functions.php file

    Avatar of marc birkett
    marc birkett
    Member

    @marc-birkett

    Hi!

    Thanks for the reply – this wasn’t in the theme so I have enqueue’d it in functions.php but no change. I then installed the default wordpress theme and no change there either….

    Any other suggestions?

    Thanks

    Marc

    Avatar of Paul Gibbs
    Paul Gibbs
    Keymaster

    @djpaul

    Switch to the twentyeleven theme. Disable BuddyPress.

    Can you reply to comments on posts/pages then?

    Avatar of marc birkett
    marc birkett
    Member

    @marc-birkett

    You know I can’t. Off to have an investigate.

    Well caught!.

    Avatar of marc birkett
    marc birkett
    Member

    @marc-birkett

    I can in other sites in my network but not that particular one….

    Avatar of marc birkett
    marc birkett
    Member

    @marc-birkett

    Solved. Just for completeness I found the solution to my problem here:

    http://wordpress.org/support/topic/comments-on-inner-multisite-not-working-404-error-on-post-url

    and added a new rule to my web.config to forward to the appropriate page:

    Avatar of rodtrent
    rodtrent
    Participant

    @rodtrent

    @marc-birkett So…what exactly did you add to your web.config? Your link talks about the htaccess file which isn’t available for IIS.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.