Skip to:
Content
Pages
Categories
Search
Top
Bottom

SideBar Whos Online and Recently Active

  • In my sidebar for the whos online and recently active the avatars are listed in a vertical format. It should look or at least I would think it should be formated in a horizontal format.

    How can I fix whatever is causing this? I really want to use these sidebar widgets but I need them to look good as well.

    Could the fact that I have buddypress installed in a secondary blog with multisite have anything to do with it? Its also using buddypress template pack but I’ve transfered over at least what I think is most of the CSS.

    Any help is really appreciated. I’m excited to officially launch this social networking portion to my website.

    Thanks,
    EOR

Viewing 20 replies - 1 through 20 (of 20 total)
  • Avatar of LPH2005
    LPH2005
    Participant

    @lph2005

    Do you have a link to the site?

    w w w.endofregulation.com/community

    Bump…Anybody know how I can fix this?

    Thanks so much,
    EOR

    I honestly have been trying to fix this for days now and don’t have the slightest clue anymore of whats causing the vertical display rather than the horizontal. I’m assuming it has something to do witih the template pack I used to make my theme compatible but I really don’t know.

    Anyone else ever see this? Anybody give me some hints on how to fix it? This is driving me nuts. I just want to launch the social network.

    Thanks so much,
    EOR

    Please help!! I am lost. I’ve tried messing with everything I imagine would effect the sidebar widgets..specifically geared towards the buddypress. like i said i used the buddypress template pack. Please help.

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    @eor, I do have a solution for you! Go into your theme’s custom CSS file, and add the following CSS.

    Global Elements


    */

    }

    h1, h2, h3, h4, h5, h6 {
    margin: 5px 0 15px 0;
    }

    p { margin-bottom: 15px; }
    p:last-child { margin-bottom: 0; }

    hr {
    background-color:#E7E7E7;
    border:0 none;
    clear:both;
    height:1px;
    margin: 20px 0;
    }

    img.avatar {
    float: left;
    border: 2px solid #eee;
    }

    img.avatar {
    background: #ffffff;
    padding: 4px;
    border: 1px solid #ddd;
    /* Round Corners (native in Safari, Firefox and Chrome) */
    -moz-border-radius: 6px;
    -webkit-border-radius: 6px;
    /* Add the Shadow */
    -moz-box-shadow: 2px 2px 2px #dddddd;
    -webkit-box-shadow: 2px 2px 2px #dddddd;
    }

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    Oops, I forgot to take out the “Round Corners CSS”

    If you want your avatars to have a nice border than keep it :)

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @eor as mentioned in this thread, site url?

    Btw, why is text bold?

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    @mercime, the CSS I provided fixes the problem. This issue only happens when they are not using a buddypress default theme.

    I had the same issue and I added this, it it fixed the problem.

    Thank you both so much for helping me. @gunju2221 I’ve tried your css and thats not fixing the issue either. I’m really at a loss. Maybe its something deeper to do with my theme?

    @mercime my site url is w w w.endofregulation.com/community
    I left the url in the other thread as well so i apologize about having two threads.

    Thanks again.
    eor

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    @eor, is does work, but where exactly are you putting the CSS?

    @gunju2221 I put the css in my style.css of my current theme. I’ve also tried putting it in the bp.css for the template pack.

    Am I supposed to be putting it somewhere else?

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    No worries @eor, Yamidoo theme has sidebar style which affected the floats, add this to your theme’s style.css
    `div#sidebar div.item-avatar {
    width: 40px;
    height: 40px;
    clear: none;
    float: left;
    }`

    @gunju2221 no offense, I had the suspicion that eor’s active theme’s css was affecting the style I gave in WP.org thread, and it did with the clear: both in sidebar divs in addition to item avatar div needed to be reined in and floated

    @DJPaul @boonebgorges why is text bold? :-)

    Avatar of Virtuali
    Virtuali
    Participant

    @gunju2221

    I would tell of where to put it in correct location, but I think @mercime would like to but in front of me :)

    @mercime you are awesome!! That worked perfectly! Now I can actually go to bed tonight ha. You don’t happen to know how to fix my this issue as well do you? ….when i type in endofregulation.com/community it takes me to w w w.endofregulation.com. Easy way to fix it?

    Thanks for the help again both to you and @gunju2221

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @eor glad to help:-) Btw, in your WP.org forum thread, point to this topic in post, then click on resolved in right sidebar of your topic in WP.

    As for the issue of the no-www domain name not redirecting to your www domain name, it’s a matter of server with mod_rewrite rules and htaccess. WP 3.0 should have handled www and no-www of domain name based on what you have in your wp-admin/options-general.php’s “Home address url” and “Blog address url” which normally should be the same.

    Text bold because it appears this site doesn’t have the fix applied to it which closed HTML tags in forum messages. Doh.

    I want it to be with the www.

    this is my current .htaccess used for the multisite

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteRule . index.php [L]

    What do I need to change or add to have it redirect from no www to www?

    Think I Fixed it. Thanks!!!

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Thank you @DJPaul, good to see plain normal text again :-)

    You’re welcome @eor

Viewing 20 replies - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.