Skip to:
Content
Pages
Categories
Search
Top
Bottom

Theme won’t update

  • Avatar of strategicblend
    strategicblend
    Participant

    @strategicblend

    I installed buddypress and the bp template back successfully. However when I upload my edited budypress template pages they don’t appear or override on my site – the old, originally styled pages still appear.

    This isn’t a server issue so I’m wondering if there’s something else I missed in the setup process or when editing those theme files. I followed all the steps on the bp template back guide so no user-error there either.

    Thanks in advance!

Viewing 12 replies - 1 through 12 (of 12 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Might be a browser issue – clear cache. Open another kind of browser to view your revisions. Also, are you sure you uploaded the revised files in the correct folder?

    Avatar of strategicblend
    strategicblend
    Participant

    @strategicblend

    Hey mercime – cleared cache across the board with no result. And my bp template files are in the main theme’s root, per the instructions on the bp template pack plugin.

    You can check out an example here: http://s338450341.onlinehome.us/members/taylor/activity/

    I have an index.php file (in the activity folder) that has totally different styles yet this old code is still showing up.

    Avatar of strategicblend
    strategicblend
    Participant

    @strategicblend

    Anyone else have any ideas?

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    You’ve not provided enough info on your file structure to provide help on this.

    Clearly, from your screen grab, your own theme and not the default is being used, so it’s picking up on those files.

    It might be an idea to list your full folder / file structure and also which amended file isn’t being picked up

    Avatar of strategicblend
    strategicblend
    Participant

    @strategicblend

    Hey Roger – as I said above I used the BP Template Pack and followed their instructions exactly – so my file structure would mimic their setup. The theme is my own (hence the reason I used the BP Template Pack Plugin) and placed the “activity” “blogs” “members” “groups” and “forums” folders inside my theme root. When I try to edit any of the files the template pack designates (see below) nothing is updated on the site:

    * /activity/index.php
    * /blogs/index.php
    * /forums/index.php
    * /groups/index.php
    * /groups/create.php
    * /groups/single/home.php
    * /groups/single/plugins.php
    * /members/index.php
    * /members/single/home.php
    * /members/single/plugins.php
    * /registration/register.php

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    To help isolate the problem: what happens if you switch to the default BuddyPress theme – does everything work ok in that scenario?

    p.s. your original post said you just see the old styled pages, but when I visit your page, it’s actually a 404 page error that shows

    Avatar of strategicblend
    strategicblend
    Participant

    @strategicblend

    Yeah you probably shouldn’t visit the URL – its a live staging site and always changing. I only placed it above per forum etiquette. If you need examples of actual code or the actual php files themselves I can certainly provide.

    (UPDATE: I’ve told the dev team to temporarily hault any activity so you should be able to see the fully rendered site at that URL and specifically note the pages aren’t changing).

    When I switch to the original BP theme everything DOES work. But just to note, I don’t have the option of using that theme – it has to be my own custom theme.

    Avatar of Roger Coathup
    Roger Coathup
    Participant

    @rogercoathup

    Ok, so the problem is definitely with your custom theme.

    I’ll jump out now… hopefully someone who’s worked with the template pack can pick up on this one

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    I took BP Template Pack for a test spin a month or so ago, once, out of curiosity :-) Some notes:

    1. Need to make sure that you have ported the HTML div structure of original theme to template pack. Watch out for div iD’s and classes of content area and sidebar. There’s an error page on the link you provided. If I remember correctly from yesterday, it seems like you have not renamed the div surrounding your content and sidebar, otherwise the page layout would’ve looked like your regular pages even if the BP components were somewhat lacking in style

    2. If you’ve disabled the BP Template Pack CSS in options, copy the styles available in https://svn.wp-plugins.org/bp-template-pack/tags/1.0.1/bp.css to your active theme’s style.css then adjust to taste

    Avatar of strategicblend
    strategicblend
    Participant

    @strategicblend

    Great – I’ll look into both mercime!

    Avatar of technokelvin
    TechnoKelvin
    Member

    @technokelvin

    Did you ever have any luck with this? I’ve run into the same exact problem. :-/

    Avatar of technokelvin
    TechnoKelvin
    Member

    @technokelvin

    I found out how to finally modify the page. You would think by modifying the index.php in the Activity folder it would change the page, WRONG!.

    This is the path to the file that WILL modify the Activity page and all others as well.

    members/single/home.php

    This should be located in your theme folder. It only took me the majority of the my night to figure it out.

    Hope this helps.

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.