Skip to:
Content
Pages
Categories
Search
Top
Bottom

There was a problem cropping your avatar, please try uploading it again

Viewing 19 replies - 1 through 19 (of 19 total)
  • Avatar of Hugo
    Hugo
    Moderator

    @hnla

    And can you upload images in general i.e can you use the WP media library uploader to add an image to your library?

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    yes,
    I just tried.

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    Looks like you’ve fixed the issue, I see an avatar http://www.latestsightings.com/members/ossendryver/

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    That was from a long time ago.
    I recently moved over to a new host.
    Ever since then I have had this problem

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    I tried png and jpg. nothing working.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I would check with your host to see what group/owner permissions are set for uploads folder and for avatar folders.

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    I changed the file permission for the avatar folder and the uploads folder to 7 7 7 and retried.
    still nothing. I get the same error.

    Avatar of shanebpdev
    shanebp
    Participant

    @shanebp

    Permissions and owner/group are two different things.
    If you can’t change the owner/group, talk to your hosting company.

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    As shanebpx says permissions and group/owner are slightly different things what this sounds like is your web server or user does not have the correct access to be able to write to the folders/directories, as I said best contact your host to resolve this or if you have ssh access to your server then look up Linux ‘chown’ to understand how to change this around. What you don’t really want to be doing is changing perms to 777 as that’s ‘world writeable’ an insecure and unnecessary set of permissions.

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    Thanks for the replies.

    But I’m on a VPS and If I ask my host they willsay I must figure it out.
    I use WHM & cPanel.
    Is there anything in there that I must change?

    Otherwise what must I do?

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    If you have a VPS then yes there is a certain onus on you to manage your server!

    If you are managing things via a control panel then in theory when you set the user /domain cpanel should have set the correct group/owner but I can’t really advice as I don’t use control panels much, preferring to grub around on the cli interface to manage my servers.

    Use the cpanel file manager to inspect what group/owner is reported for those directories and work it out from there.

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    I’m in my cPanel.
    What do I press to check what group/owner is reported for those directories

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    I’m not sure what to do once in the cPanel

    Avatar of Hugo
    Hugo
    Moderator

    @hnla

    I suggest if you are unfamiliar with Cpanel then reading through the docs might be a good idea:

    http://docs.cpanel.net/twiki/bin/view/11_32/CpanelDocs/FileManager

    I do not know if file manager will help in this instance, but I presumed it would show you what owner/group settings were in effect for various directories, more than that I can’t really help with. i’m not sure what the issue is or whether it is related to owner/group settings but usually it is. As you have a VPS the next step might have to be familiarising yourself with the Linux command line via a shell putty, bash and looking up the use of the ‘chown’ command.

    Avatar of ossendryver
    ossendryver
    Participant

    @ossendryver

    I have looked. All seems to be normal :(

    Now what?

    Avatar of John Robben
    John Robben
    Participant

    @nwwaterboy

    I am having the same problem:

    I am trying to upload a picture from my computer for an avatar. Size at 50×50 and 100×100 , 300×150 the pictures upload fine, then the crop picture button and select box, after expanding the selection box for cropping ( the section to be cropped shows up next to picture) clicking crop picture button, refreshes the screen and produces this error .. There was a problem cropping your avatar, please try uploading it again. Tried this multiple times in both current versions of FF and Chrome. Same results.

    ps. I had buddypress media plugin installed after deleting the problem was the same.

    A bit more background, tracked back the location of the avatar pictures – wp-content/uploads/avatars ; The owner and group on the dir, subdir, and files are siteower and siteowner just like all of the other folders and files – the directory was set to 755 and files to 644; there were jpgs in my avatar folder for all my attempts at adding an avatar. Just to see what happened I changed all the files to 755 and attempted another upload, same error and the uploaded file had the permission set at 644.
    Process details:
    The upload worked , then the crop function fired and after including the full 100×100 image in crop selection and clicking crop. The Same “here was a problem cropping your avatar, please try uploading it again.” Error came up again.

    Any suggestions?

    System info:

    Infinity Version: 1.1a
    Developer Mode: Disabled
    BuddyPress: 1.6.1
    MySQL: 5.1.66
    Permalinks: custom
    PHP: 5.3.2-1ubuntu4.18
    WordPress: 3.4.2
    WordPress multisite: no

    Avatar of John Robben
    John Robben
    Participant

    @nwwaterboy

    Update:
    I also repeated the process above with the default buddypress theme activated and the problem issues were the same.

    I also found from a post a couple of years ago that it could be that there was not a GD image package installed on the server. We have the following installed:

    GD Graphics Library version 2
    GD is a graphics library. It allows your code to quickly draw images
    complete with lines, arcs, text, multiple colours, cut and paste from
    other images, flood fills, and write out the result as a PNG file.
    This is particularly useful in World Wide Web applications, where PNG is
    one of the formats accepted for inline images by most browsers.
    .
    This is the runtime package of the library, built with XPM (X pixmap)
    and fontconfig support.
    Homepage: http://www.libgd.org/
    Original-Maintainer: GD team
    Package libgd2-xpm
    Class K-O
    Version 2.0.36~rc1~dfsg-3.1ubuntu1
    Vendor Ubuntu Core Developers
    Architecture amd64

    Avatar of John Robben
    John Robben
    Participant

    @nwwaterboy

    Loading these 2 packages fixed the avatar cropping problem on our site
    php5-curl 5.3.2-1ubuntu4.18 CURL module for php5
    php5-gd 5.3.2-1ubuntu4.18 GD module for php5

    Avatar of stefwilliams
    stefwilliams
    Participant

    @stefwilliams

    I was having this same issue and none of the posted solutions was working. In the end, it turned out that it was because the filename of the avatar image was the problem (I presume too long).
    Basically, I was testing uploading an autogenerated filename (32203c6ae1bc3723a3432a38b1185490-bpthumb.jpg).
    This failed with the non-descript error: There was a problem cropping the avatar.
    I shortened the filename, and BAM! all works fine.
    In that none of the posts I’ve seen around this problem suggest the filename as being a problem, I thought I’d post my solution.
    (May be worth adding an error check to bp-core-avatars.php ?)

Viewing 19 replies - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.