Skip to:
Content
Pages
Categories
Search
Top
Bottom

[Resolved] toolbar disappears for users

  • Avatar of John Conner
    John Conner
    Participant

    @johnconner

    hi everyone, I’m newbie in BP zone. I installed the plugin successfully and everything seem well except one: the admin bar is shown just for administrator and logged out users. when a none admin user get in, the toolbar goes disappeared (wordpress toolbar check was considered). I searched a lot for the reason with no conclusion (like add codes to functions.php,wp-config.php or change user role settings). any idea for the reason will be appreciated…

Viewing 5 replies - 1 through 5 (of 5 total)
  • Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    What theme are you using? Have you tried changing to BP Default theme to see if issue is resolved?

    What plugins are installed? Have you tried deactivating all plugins except BuddyPress to check if wp-admin shows up as expected? If that works, activate plugins one by one to check which is causing the mystery of the missing toolbar.

    Avatar of John Conner
    John Conner
    Participant

    @johnconner

    thanks a lot for the clue, it was “theme my login” themed profiles module. I changed this line in the module’s php file and everything goes perfect:

    `if ( $theme_my_login->options->get_option( array( ‘themed_profiles’, $user_role, ‘restrict_admin’ ) ) )
    return true;`

    Avatar of @mercime
    @mercime
    Keymaster

    @mercime

    @johnconner You’re welcome. Thanks for sharing how you solved the issue :-)
    Marking this as resolved.

    Avatar of hamedharry
    NumberOneComputer
    Participant

    @hamedharry

    I have same problem
    I use BP Default theme & my theme but both of them my users can’t see it & my all plugin is same as before

    I didn’t have problem with buddypress 1.6.4

    Link to my site>you can go to my profile

    Best regards

    Avatar of berrybatter
    berrybatter
    Participant

    @berrybatter

    @johnconner, would you be able to let me know the exact line you replaced with the new line? I’m not technical at all, and am having a hard time figuring out which line in the themed profiles module to replace. Would really appreciate your help!

Viewing 5 replies - 1 through 5 (of 5 total)

The topic ‘[Resolved] toolbar disappears for users’ is closed to new replies.